summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.7.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.7.9-r2.ebuild')
-rw-r--r--dev-lang/python/python-3.7.9-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.7.9-r2.ebuild b/dev-lang/python/python-3.7.9-r2.ebuild
index 7b22ccdb26a0..4af9ba14bd81 100644
--- a/dev-lang/python/python-3.7.9-r2.ebuild
+++ b/dev-lang/python/python-3.7.9-r2.ebuild
@@ -22,7 +22,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc ~x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -167,6 +167,12 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {