summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.7.0.ebuild')
-rw-r--r--dev-lang/python/python-3.7.0.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-lang/python/python-3.7.0.ebuild b/dev-lang/python/python-3.7.0.ebuild
index d1ab60b3112d..e3cebf3af955 100644
--- a/dev-lang/python/python-3.7.0.ebuild
+++ b/dev-lang/python/python-3.7.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
LICENSE="PSF-2"
SLOT="3.7/3.7m"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
@@ -139,12 +139,6 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
-
- if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
- eerror "configure has detected that the sem_open function is broken."
- eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
- die "Broken sem_open function (bug 496328)"
- fi
}
src_compile() {
@@ -238,7 +232,6 @@ src_install() {
use sqlite || rm -r "${libdir}/"{sqlite3,test/test_sqlite*} || die
use tk || rm -r "${ED%/}/usr/bin/idle${PYVER}" "${libdir}/"{idlelib,tkinter,test/test_tk*} || die
- use threads || rm -r "${libdir}/multiprocessing" || die
use wininst || rm "${libdir}/distutils/command/"wininst-*.exe || die
dodoc "${S}"/Misc/{ACKS,HISTORY,NEWS}