summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.6.14_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.6.14_p1.ebuild')
-rw-r--r--dev-lang/python/python-3.6.14_p1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.6.14_p1.ebuild b/dev-lang/python/python-3.6.14_p1.ebuild
index c375dd63ae3a..03a62d2284c3 100644
--- a/dev-lang/python/python-3.6.14_p1.ebuild
+++ b/dev-lang/python/python-3.6.14_p1.ebuild
@@ -22,8 +22,8 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 +ncurses +readline +sqlite +ssl test +threads tk wininst +xml"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc ~x86"
+IUSE="bluetooth build examples gdbm hardened +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
@@ -151,8 +151,8 @@ src_configure() {
--with-fpectl
--enable-shared
- $(use_enable ipv6)
- $(use_with threads)
+ --enable-ipv6
+ --with-threads
--infodir='${prefix}/share/info'
--mandir='${prefix}/share/man'
--with-computed-gotos
@@ -166,7 +166,7 @@ src_configure() {
OPT="" econf "${myeconfargs[@]}"
- if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
@@ -269,7 +269,6 @@ src_install() {
use sqlite || rm -r "${libdir}/"{sqlite3,test/test_sqlite*} || die
use tk || rm -r "${ED}/usr/bin/idle${PYVER}" "${libdir}/"{idlelib,tkinter,test/test_tk*} || die
- use threads || rm -r "${libdir}/multiprocessing" || die
use wininst || rm "${libdir}/distutils/command/"wininst-*.exe || die
dodoc Misc/{ACKS,HISTORY,NEWS}