summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.12.0_alpha1_p1.ebuild')
-rw-r--r--dev-lang/python/python-3.12.0_alpha1_p1.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
index 8d748fa37b67..df8279e32c7e 100644
--- a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
@@ -149,11 +149,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -216,13 +211,14 @@ src_configure() {
# disable implicit optimization/debugging flags
local -x OPT=
- # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
- # propagated to sysconfig for built extensions
- local -x CFLAGS_NODIST=${CFLAGS}
- local -x LDFLAGS_NODIST=${LDFLAGS}
- local -x CFLAGS= LDFLAGS=
if tc-is-cross-compiler ; then
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
+ local -x LDFLAGS_NODIST=${LDFLAGS_FOR_BUILD}
+ local -x CFLAGS= LDFLAGS=
+
# We need to build our own Python on CBUILD first, and feed it in.
# bug #847910
local myeconfargs_cbuild=(
@@ -270,6 +266,17 @@ src_configure() {
popd &> /dev/null || die
fi
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS}
+ local -x LDFLAGS_NODIST=${LDFLAGS}
+ local -x CFLAGS= LDFLAGS=
+
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then