summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.10.8_p3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.10.8_p3.ebuild')
-rw-r--r--dev-lang/python/python-3.10.8_p3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.10.8_p3.ebuild b/dev-lang/python/python-3.10.8_p3.ebuild
index f7df03edfe54..ca2055bc531c 100644
--- a/dev-lang/python/python-3.10.8_p3.ebuild
+++ b/dev-lang/python/python-3.10.8_p3.ebuild
@@ -31,7 +31,7 @@ SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
bluetooth build +ensurepip examples gdbm hardened libedit lto
- +ncurses pgo +readline +sqlite +ssl test tk +xml
+ +ncurses pgo +readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -71,6 +71,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
+ valgrind? ( dev-util/valgrind )
test? ( app-arch/xz-utils[extra-filters(+)] )
"
# autoconf-archive needed to eautoreconf
@@ -222,6 +223,7 @@ src_configure() {
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
+ $(use_with valgrind)
)
# disable implicit optimization/debugging flags