summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.10.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.10.8.ebuild')
-rw-r--r--dev-lang/python/python-3.10.8.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-lang/python/python-3.10.8.ebuild b/dev-lang/python/python-3.10.8.ebuild
index 625f41d24ffb..0b7ad7f2c527 100644
--- a/dev-lang/python/python-3.10.8.ebuild
+++ b/dev-lang/python/python-3.10.8.ebuild
@@ -231,13 +231,14 @@ src_configure() {
# disable implicit optimization/debugging flags
local -x OPT=
- # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
- # propagated to sysconfig for built extensions
- local -x CFLAGS_NODIST=${CFLAGS}
- local -x LDFLAGS_NODIST=${LDFLAGS}
- local -x CFLAGS= LDFLAGS=
if tc-is-cross-compiler ; then
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
+ local -x LDFLAGS_NODIST=${LDFLAGS_FOR_BUILD}
+ local -x CFLAGS= LDFLAGS=
+
# We need to build our own Python on CBUILD first, and feed it in.
# bug #847910 and bug #864911.
local myeconfargs_cbuild=(
@@ -282,6 +283,12 @@ src_configure() {
popd &> /dev/null || die
fi
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS}
+ local -x LDFLAGS_NODIST=${LDFLAGS}
+ local -x CFLAGS= LDFLAGS=
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then