summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.10.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.10.11.ebuild')
-rw-r--r--dev-lang/python/python-3.10.11.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index fa6da52fc33b..36d2fa653fd4 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -180,9 +180,14 @@ src_configure() {
-m test
"-j$(makeopts_jobs)"
--pgo-extended
- -x test_gdb
-u-network
+ # We use a timeout because of how often we've had hang issues
+ # here. It also matches the default upstream PROFILE_TASK.
+ --timeout 1200
+
+ -x test_gdb
+
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
@@ -192,6 +197,10 @@ src_configure() {
-x test_multiprocessing_fork
-x test_socket
-x test_xmlrpc
+
+ # Hangs (actually runs indefinitely executing itself w/ many cpython builds)
+ # bug #900429
+ -x test_tools
)
if has_version "app-arch/rpm" ; then