summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.1.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-8.1.21.ebuild')
-rw-r--r--dev-lang/php/php-8.1.21.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-lang/php/php-8.1.21.ebuild b/dev-lang/php/php-8.1.21.ebuild
index db53ccbaa5bb..1e3a6c509724 100644
--- a/dev-lang/php/php-8.1.21.ebuild
+++ b/dev-lang/php/php-8.1.21.ebuild
@@ -245,6 +245,9 @@ src_configure() {
PHP_DESTDIR="${EPREFIX}/usr/$(get_libdir)/php${SLOT}"
+ # https://bugs.gentoo.org/866683, https://bugs.gentoo.org/913527
+ filter-lto
+
# The php-fpm config file wants localstatedir to be ${EPREFIX}/var
# and not the Gentoo default ${EPREFIX}/var/lib. See bug 572002.
local our_conf=(
@@ -259,11 +262,6 @@ src_configure() {
$(use_enable threads zts)
)
- if is-flagq -flto; then
- # https://bugs.gentoo.org/866683
- our_conf+=( --disable-gcc-global-regs )
- fi
-
our_conf+=(
$(use_with apparmor fpm-apparmor)
$(use_with argon2 password-argon2 "${EPREFIX}/usr")