summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-7.4.0_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-7.4.0_rc1.ebuild')
-rw-r--r--dev-lang/php/php-7.4.0_rc1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/php/php-7.4.0_rc1.ebuild b/dev-lang/php/php-7.4.0_rc1.ebuild
index 4c04d93e4d4d..fafdcb64e838 100644
--- a/dev-lang/php/php-7.4.0_rc1.ebuild
+++ b/dev-lang/php/php-7.4.0_rc1.ebuild
@@ -218,9 +218,11 @@ src_prepare() {
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
- # Bug 669566 - necessary so that build tools are updated for commands like pecl
- cp "${BROOT}/usr/share/aclocal/libtool.m4" build/ || die
- eautoreconf
+ # Emulate buildconf to support cross-compilation
+ rm -fr aclocal.m4 autom4te.cache config.cache \
+ configure main/php_config.h.in || die
+ eautoconf --force
+ eautoheader
}
src_configure() {