summaryrefslogtreecommitdiff
path: root/dev-lang/perl/perl-5.28.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.28.9999.ebuild')
-rw-r--r--dev-lang/perl/perl-5.28.9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/perl/perl-5.28.9999.ebuild b/dev-lang/perl/perl-5.28.9999.ebuild
index bacc75e30d88..71fc2b82b39b 100644
--- a/dev-lang/perl/perl-5.28.9999.ebuild
+++ b/dev-lang/perl/perl-5.28.9999.ebuild
@@ -307,8 +307,6 @@ src_prepare() {
# do NOT mess with nsl, on Solaris this is always necessary,
# when -lsocket is used e.g. to get h_errno
sed -i '/gentoo\/no-nsl\.patch/d' "${WORKDIR}/patches/series" || die
- # and set a soname
- sed -i 's/sunos\*/sunos*|solaris*/' Makefile.SH || die
fi
einfo "Applying patches from ${PATCH_BASE} ..."
@@ -333,6 +331,11 @@ src_prepare() {
sed -i "/my..sysroot/s:'':'${EPREFIX}':" ext/Errno/Errno_pm.PL || die
fi
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # set a soname, fix linking against just built libperl
+ sed -i -e 's/netbsd\*/netbsd*|solaris*/' Makefile.SH || die
+ fi
+
default
}