summaryrefslogtreecommitdiff
path: root/dev-lang/nasm/nasm-2.15.05.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nasm/nasm-2.15.05.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.15.05.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/dev-lang/nasm/nasm-2.15.05.ebuild b/dev-lang/nasm/nasm-2.15.05.ebuild
index c8a16b87337d..297cea8bba39 100644
--- a/dev-lang/nasm/nasm-2.15.05.ebuild
+++ b/dev-lang/nasm/nasm-2.15.05.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
-
DESCRIPTION="groovy little assembler"
HOMEPAGE="https://www.nasm.us/"
SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ia64 ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND=""
-DEPEND=""
# [fonts note] doc/psfonts.ph defines ordered list of font preference.
# Currently 'media-fonts/source-pro' is most preferred and is able to
# satisfy all 6 font flavours: tilt, chapter, head, etc.
@@ -30,8 +27,6 @@ BDEPEND="
)
"
-S=${WORKDIR}/${P/_}
-
PATCHES=(
"${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
)
@@ -43,5 +38,5 @@ src_compile() {
src_install() {
default
- emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+ emake DESTDIR="${ED}" install_rdf $(usex doc install_doc '')
}