summaryrefslogtreecommitdiff
path: root/dev-lang/mmix/mmix-20131017.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mmix/mmix-20131017.ebuild')
-rw-r--r--dev-lang/mmix/mmix-20131017.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-lang/mmix/mmix-20131017.ebuild b/dev-lang/mmix/mmix-20131017.ebuild
deleted file mode 100644
index 7e736d6cecff..000000000000
--- a/dev-lang/mmix/mmix-20131017.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
-HOMEPAGE="https://www-cs-faculty.stanford.edu/~knuth/mmix.html http://mmix.cs.hm.edu"
-SRC_URI="http://mmix.cs.hm.edu/src/${P}.tgz"
-
-DEPEND="virtual/tex-base
- doc? ( dev-texlive/texlive-plaingeneric )"
-RDEPEND=""
-
-SLOT="0"
-LICENSE="${PN}"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-20110420-makefile.patch
- epatch "${FILESDIR}"/${PN}-20131017-format-security.patch
-}
-
-src_compile() {
- export VARTEXFONTS=${T}/fonts
- emake all \
- CFLAGS="${CFLAGS}" \
- CC="$(tc-getCC)"
-
- if use doc ; then
- emake doc
- fi
-}
-
-src_install () {
- dobin ${PN} ${PN}al m${PN} mmotype abstime
- dodoc README ${PN}.1
-
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins *.ps
- fi
-}