summaryrefslogtreecommitdiff
path: root/dev-lang/lua/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua/files')
-rw-r--r--dev-lang/lua/files/5.2.0/01_all_memory_hoarding.upstream.patch49
-rw-r--r--dev-lang/lua/files/5.2.0/02_all_hex_number_handling.upstream.patch26
-rw-r--r--dev-lang/lua/files/lua-5.2.4-make.patch75
3 files changed, 0 insertions, 150 deletions
diff --git a/dev-lang/lua/files/5.2.0/01_all_memory_hoarding.upstream.patch b/dev-lang/lua/files/5.2.0/01_all_memory_hoarding.upstream.patch
deleted file mode 100644
index 9fda24ad6609..000000000000
--- a/dev-lang/lua/files/5.2.0/01_all_memory_hoarding.upstream.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- lua-5.2.0.orig/src/ldblib.c 2007/12/28 15:32:23 2.25.1.3
-+++ lua-5.2.0/src/ldblib.c 2009/06/15 14:07:34
-@@ -253,14 +253,15 @@
- }
-
-
--#define gethooktable(L) luaL_getsubtable(L, LUA_REGISTRYINDEX, HOOKKEY);
-+#define gethooktable(L) luaL_getsubtable(L, LUA_REGISTRYINDEX, HOOKKEY)
-
-
- static void hookf (lua_State *L, lua_Debug *ar) {
- static const char *const hooknames[] =
- {"call", "return", "line", "count", "tail call"};
- gethooktable(L);
-- lua_rawgetp(L, -1, L);
-+ lua_pushthread(L);
-+ lua_rawget(L, -2);
- if (lua_isfunction(L, -1)) {
- lua_pushstring(L, hooknames[(int)ar->event]);
- if (ar->currentline >= 0)
-@@ -306,10 +307,15 @@
- count = luaL_optint(L, arg+3, 0);
- func = hookf; mask = makemask(smask, count);
- }
-- gethooktable(L);
-+ if (gethooktable(L) == 0) { /* creating hook table? */
-+ lua_pushstring(L, "k");
-+ lua_setfield(L, -2, "__mode"); /** hooktable.__mode = "k" */
-+ lua_pushvalue(L, -1);
-+ lua_setmetatable(L, -2); /* setmetatable(hooktable) = hooktable */
-+ }
-+ lua_pushthread(L1); lua_xmove(L1, L, 1);
- lua_pushvalue(L, arg+1);
-- lua_rawsetp(L, -2, L1); /* set new hook */
-- lua_pop(L, 1); /* remove hook table */
-+ lua_rawset(L, -3); /* set new hook */
- lua_sethook(L1, func, mask, count); /* set hooks */
- return 0;
- }
-@@ -325,7 +331,8 @@
- lua_pushliteral(L, "external hook");
- else {
- gethooktable(L);
-- lua_rawgetp(L, -1, L1); /* get hook */
-+ lua_pushthread(L1); lua_xmove(L1, L, 1);
-+ lua_rawget(L, -2); /* get hook */
- lua_remove(L, -2); /* remove hook table */
- }
- lua_pushstring(L, unmakemask(mask, buff));
diff --git a/dev-lang/lua/files/5.2.0/02_all_hex_number_handling.upstream.patch b/dev-lang/lua/files/5.2.0/02_all_hex_number_handling.upstream.patch
deleted file mode 100644
index 26519e378e68..000000000000
--- a/dev-lang/lua/files/5.2.0/02_all_hex_number_handling.upstream.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- lua-5.2.0.orig/src/llex.c 2007/12/28 15:32:23 2.25.1.3
-+++ lua-5.2.0/src/llex.c 2009/06/15 14:07:34
-@@ -223,12 +223,19 @@
-
- /* LUA_NUMBER */
- static void read_numeral (LexState *ls, SemInfo *seminfo) {
-+ const char *expo = "Ee";
-+ int first = ls->current;
- lua_assert(lisdigit(ls->current));
-- do {
-- save_and_next(ls);
-- if (check_next(ls, "EePp")) /* exponent part? */
-+ save_and_next(ls);
-+ if (first == '0' && check_next(ls, "Xx")) /* hexadecimal? */
-+ expo = "Pp";
-+ for (;;) {
-+ if (check_next(ls, expo)) /* exponent part? */
- check_next(ls, "+-"); /* optional exponent sign */
-- } while (lislalnum(ls->current) || ls->current == '.');
-+ if (lisxdigit(ls->current) || ls->current == '.')
-+ save_and_next(ls);
-+ else break;
-+ }
- save(ls, '\0');
- buffreplace(ls, '.', ls->decpoint); /* follow locale for decimal point */
- if (!buff2d(ls->buff, &seminfo->r)) /* format error? */
diff --git a/dev-lang/lua/files/lua-5.2.4-make.patch b/dev-lang/lua/files/lua-5.2.4-make.patch
deleted file mode 100644
index 40e1f5aa7d0c..000000000000
--- a/dev-lang/lua/files/lua-5.2.4-make.patch
+++ /dev/null
@@ -1,75 +0,0 @@
---- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
-+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -11,7 +11,7 @@
- # so take care if INSTALL_TOP is not an absolute path.
- INSTALL_TOP= /usr/local
- INSTALL_BIN= $(INSTALL_TOP)/bin
--INSTALL_INC= $(INSTALL_TOP)/include
-+INSTALL_INC= $(INSTALL_TOP)/include/lua$V
- INSTALL_LIB= $(INSTALL_TOP)/lib
- INSTALL_MAN= $(INSTALL_TOP)/man/man1
- #
-@@ -127,3 +127,18 @@
- .PHONY: all $(PLATS) clean install local none dummy echo pecho lecho newer
-
- # (end of Makefile)
-+
-+# Use libtool for binary installs, etc.
-+
-+export V
-+export LIBTOOL = libtool --quiet --tag=CC
-+# See libtool manual about how to set this
-+
-+gentoo_clean:
-+ cd src; $(MAKE) $@
-+
-+gentoo_install:
-+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua$V luac$V $(INSTALL_BIN)
-+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua$V.la $(INSTALL_LIB)
---- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
-+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
-@@ -39,1 +39,1 @@
--LUA_T= lua
-+LUA_T= lua$V
-@@ -42,1 +42,1 @@
--LUAC_T= luac
-+LUAC_T= luac$V
-@@ -54,1 +54,1 @@
--$(LUA_T): $(LUA_O) $(LUA_A)
-+origin$(LUA_T): $(LUA_O) $(LUA_A)
-@@ -57,1 +57,1 @@
--$(LUAC_T): $(LUAC_O) $(LUA_A)
-+origin$(LUAC_T): $(LUAC_O) $(LUA_A)
-@@ -185,3 +185,30 @@
- lzio.o: lzio.c lua.h luaconf.h llimits.h lmem.h lstate.h lobject.h ltm.h \
- lzio.h
-
-+
-+export LIBTOOL = libtool --quiet --tag=CC
-+export LIB_VERSION = 6:1:1
-+
-+# The following rules use libtool for compiling and linking in order to
-+# provide shared library support.
-+
-+LIB_NAME = liblua$V.la
-+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
-+
-+%.lo %.o: %.c
-+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
-+
-+$(LIB_NAME): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
-+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-+
-+$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
-+
-+$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
-+
-+gentoo_clean:
-+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua$V luac$V
-+
-+gentoo_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)