summaryrefslogtreecommitdiff
path: root/dev-lang/lua/files/lua-5.3-make-r1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua/files/lua-5.3-make-r1.patch')
-rw-r--r--dev-lang/lua/files/lua-5.3-make-r1.patch91
1 files changed, 0 insertions, 91 deletions
diff --git a/dev-lang/lua/files/lua-5.3-make-r1.patch b/dev-lang/lua/files/lua-5.3-make-r1.patch
deleted file mode 100644
index d27eb9938ea0..000000000000
--- a/dev-lang/lua/files/lua-5.3-make-r1.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-diff -uNr lua-5.3.3.orig/Makefile lua-5.3.3/Makefile
---- lua-5.3.3.orig/Makefile 2016-12-04 22:29:54.839135901 +0100
-+++ lua-5.3.3/Makefile 2016-12-04 22:31:14.235851109 +0100
-@@ -12,7 +12,7 @@
- # LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
- INSTALL_TOP= /usr/local
- INSTALL_BIN= $(INSTALL_TOP)/bin
--INSTALL_INC= $(INSTALL_TOP)/include
-+INSTALL_INC= $(INSTALL_TOP)/include/lua$V
- INSTALL_LIB= $(INSTALL_TOP)/lib
- INSTALL_MAN= $(INSTALL_TOP)/man/man1
- INSTALL_LMOD= $(INSTALL_TOP)/share/lua/$V
-@@ -112,3 +112,18 @@
- .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho
-
- # (end of Makefile)
-+
-+# Use libtool for binary installs, etc.
-+
-+export V
-+export LIBTOOL = libtool --quiet --tag=CC
-+# See libtool manual about how to set this
-+
-+gentoo_clean:
-+ cd src; $(MAKE) $@
-+
-+gentoo_install:
-+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua$V luac$V $(INSTALL_BIN)
-+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua$V.la $(INSTALL_LIB)
-diff -uNr lua-5.3.3.orig/src/Makefile lua-5.3.3/src/Makefile
---- lua-5.3.3.orig/src/Makefile 2016-12-04 22:29:54.840135910 +0100
-+++ lua-5.3.3/src/Makefile 2016-12-04 22:34:55.980848068 +0100
-@@ -36,10 +36,10 @@
- lmathlib.o loslib.o lstrlib.o ltablib.o lutf8lib.o loadlib.o linit.o
- BASE_O= $(CORE_O) $(LIB_O) $(MYOBJS)
-
--LUA_T= lua
-+LUA_T= lua$V
- LUA_O= lua.o
-
--LUAC_T= luac
-+LUAC_T= luac$V
- LUAC_O= luac.o
-
- ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-@@ -59,10 +59,10 @@
- $(AR) $@ $(BASE_O)
- $(RANLIB) $@
-
--$(LUA_T): $(LUA_O) $(LUA_A)
-+origin$(LUA_T): $(LUA_O) $(LUA_A)
- $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-
--$(LUAC_T): $(LUAC_O) $(LUA_A)
-+origin$(LUAC_T): $(LUAC_O) $(LUA_A)
- $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
-
- clean:
-@@ -195,3 +195,30 @@
- lobject.h ltm.h lzio.h
-
- # (end of Makefile)
-+
-+export LIBTOOL = libtool --quiet --tag=CC
-+export LIB_VERSION = 6:1:1
-+
-+# The following rules use libtool for compiling and linking in order to
-+# provide shared library support.
-+
-+LIB_NAME = liblua$V.la
-+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
-+
-+%.lo %.o: %.c
-+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
-+
-+$(LIB_NAME): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
-+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-+
-+$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
-+
-+$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
-+
-+gentoo_clean:
-+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua$V luac$V
-+
-+gentoo_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)