summaryrefslogtreecommitdiff
path: root/dev-lang/julia/files/julia-1.9.4-string-replace.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files/julia-1.9.4-string-replace.patch')
-rw-r--r--dev-lang/julia/files/julia-1.9.4-string-replace.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-lang/julia/files/julia-1.9.4-string-replace.patch b/dev-lang/julia/files/julia-1.9.4-string-replace.patch
new file mode 100644
index 000000000000..7f5497bdac8f
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.9.4-string-replace.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index c742a9f..a38edee 100644
+--- a/Makefile
++++ b/Makefile
+@@ -232,7 +232,7 @@ endif
+ # Note that we disable MSYS2's path munging here, as otherwise
+ # it replaces our `:`-separated list as a `;`-separated one.
+ define stringreplace
+- MSYS2_ARG_CONV_EXCL='*' $(build_depsbindir)/stringreplace $$(strings -t x - '$1' | grep "$2" | awk '{print $$1;}') "$3" 255 "$(call cygpath_w,$1)"
++ MSYS2_ARG_CONV_EXCL='*' $(build_depsbindir)/stringreplace $$(strings -t x - "$1" | grep "$2" | awk '{print $$1;}') "$3" 255 "$(call cygpath_w,$1)"
+ endef
+
+