summaryrefslogtreecommitdiff
path: root/dev-lang/jint/jint-3.0.0_beta2051.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/jint/jint-3.0.0_beta2051.ebuild')
-rw-r--r--dev-lang/jint/jint-3.0.0_beta2051.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-lang/jint/jint-3.0.0_beta2051.ebuild b/dev-lang/jint/jint-3.0.0_beta2051.ebuild
index 531b441dfbbd..fc437c26d904 100644
--- a/dev-lang/jint/jint-3.0.0_beta2051.ebuild
+++ b/dev-lang/jint/jint-3.0.0_beta2051.ebuild
@@ -44,8 +44,6 @@ microsoft.netcore.platforms@2.1.2
microsoft.netcore.platforms@5.0.0
microsoft.netcore.targets@1.1.0
microsoft.netcore.targets@1.1.3
-microsoft.netframework.referenceassemblies.net462@1.0.2
-microsoft.netframework.referenceassemblies@1.0.2
microsoft.sourcelink.common@1.1.1
microsoft.sourcelink.github@1.1.1
microsoft.testplatform.objectmodel@17.7.1
@@ -233,6 +231,12 @@ SLOT="0"
RESTRICT="test" # Tests fail.
CHECKREQS_DISK_BUILD="2G"
+DOTNET_PKG_RESTORE_EXTRA_ARGS=(
+ -p:TargetFramework="net${DOTNET_PKG_COMPAT}"
+ -p:TargetFrameworks="net${DOTNET_PKG_COMPAT}"
+)
+DOTNET_PKG_BUILD_EXTRA_ARGS=( "${DOTNET_PKG_RESTORE_EXTRA_ARGS[@]}" )
+DOTNET_PKG_TEST_EXTRA_ARGS=( "${DOTNET_PKG_RESTORE_EXTRA_ARGS[@]}" )
DOTNET_PKG_PROJECTS=( Jint.Repl/Jint.Repl.csproj )
pkg_setup() {
@@ -240,17 +244,6 @@ pkg_setup() {
dotnet-pkg_pkg_setup
}
-src_prepare() {
- default
-
- # Force update to SDK 7.0 since build fails with current version
- # of SDK 6.0 in the ::gentoo tree.
- find . \
- -type f -name "*.csproj" \
- -exec sed -e "s|net6.0|net7.0|g" -i {} \; \
- || die
-}
-
src_install() {
dotnet-pkg-base_install
dotnet-pkg-base_dolauncher "/usr/share/${P}/Jint.Repl" "${PN}"