summaryrefslogtreecommitdiff
path: root/dev-lang/go/go-1.18.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/go/go-1.18.5.ebuild')
-rw-r--r--dev-lang/go/go-1.18.5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/go/go-1.18.5.ebuild b/dev-lang/go/go-1.18.5.ebuild
index 7b657c57834f..217891046702 100644
--- a/dev-lang/go/go-1.18.5.ebuild
+++ b/dev-lang/go/go-1.18.5.ebuild
@@ -21,7 +21,7 @@ case ${PV} in
case ${PV} in
*_beta*|*_rc*) ;;
*)
- KEYWORDS="-* amd64 arm arm64 ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
;;
esac
esac
@@ -64,14 +64,14 @@ README.md
go_arch() {
# By chance most portage arch names match Go
- local tc_arch=$(tc-arch $@)
- case "${tc_arch}" in
+ local portage_arch=$(tc-arch $@)
+ case "${portage_arch}" in
x86) echo 386;;
x64-*) echo amd64;;
ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
riscv) echo riscv64 ;;
s390) echo s390x ;;
- *) echo "${tc_arch}";;
+ *) echo "${portage_arch}";;
esac
}