summaryrefslogtreecommitdiff
path: root/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
index 09374e55ce58..c90d5ac44036 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
@@ -79,10 +79,10 @@ src_prepare() {
die "ada compiler not available"
fi
+ local bundledchost=""
+ use amd64 && local bundledchost="x86_64"
+ use x86 && local bundledchost="i686"
if use bootstrap; then
- local bundledchost=""
- use amd64 && local bundledchost="x86_64"
- use x86 && local bundledchost="i686"
rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/${bundledchost}-pc-linux-gnu/4.7.4/ld \
|| die
ln -s /usr/bin/$CHOST-ld \
@@ -113,6 +113,12 @@ src_prepare() {
ln -s $(type -P ${GNATBIND}) bin/gnatbind || die
ln -s $(type -P ${GNATLINK}) bin/gnatlink || die
ln -s $(type -P ${GNATLS}) bin/gnatls || die
+ ln -s $(type -P ${GCC}) bin/${bundledchost}-pc-linux-gnu-gcc || die
+ ln -s $(type -P ${CXX}) bin/${bundledchost}-pc-linux-gnu-g++ || die
+ ln -s $(type -P ${GNATMAKE}) bin/${bundledchost}-pc-linux-gnu-gnatmake || die
+ ln -s $(type -P ${GNATBIND}) bin/${bundledchost}-pc-linux-gnu-gnatbind || die
+ ln -s $(type -P ${GNATLINK}) bin/${bundledchost}-pc-linux-gnu-gnatlink || die
+ ln -s $(type -P ${GNATLS}) bin/${bundledchost}-pc-linux-gnu-gnatls || die
cd ..
mv ${GNATDIR}/src/ada ${MYP}/gcc/ || die