summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-9.0.2-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-9.0.2-r4.ebuild')
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r4.ebuild32
1 files changed, 26 insertions, 6 deletions
diff --git a/dev-lang/ghc/ghc-9.0.2-r4.ebuild b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
index 140c6cdfed30..a02446080d36 100644
--- a/dev-lang/ghc/ghc-9.0.2-r4.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
@@ -161,19 +161,28 @@ RDEPEND+="binary? ( ${PREBUILT_BINARY_RDEPENDS} )"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( app-text/docbook-xml-dtd:4.2
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+ app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
- dev-python/sphinx
- dev-python/sphinx-rtd-theme
- >=dev-libs/libxslt-1.1.2 )
- !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )
- test? ( ${PYTHON_DEPS} )
+ >=dev-libs/libxslt-1.1.2
+ )
+ !ghcbootstrap? (
+ ${PREBUILT_BINARY_DEPENDS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )
"
needs_python() {
# test driver is written in python
use test && return 0
+ use doc && return 0
return 1
}
@@ -187,6 +196,13 @@ REQUIRED_USE="
# haskell libraries built with cabal in configure mode, #515354
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-gcc"
+python_check_deps() {
+ if use doc; then
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]"
+ fi
+}
+
is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
@@ -629,6 +645,10 @@ src_prepare() {
src_configure() {
if ! use binary; then
+ # No upstream LTO support. bug #855596
+ filter-lto
+ append-flags -fno-strict-aliasing
+
# initialize build.mk
echo '# Gentoo changes' > mk/build.mk