summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-8.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-8.0.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.0.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/ghc/ghc-8.0.2.ebuild b/dev-lang/ghc/ghc-8.0.2.ebuild
index 48eb8d91db6e..6fe47f61c5f4 100644
--- a/dev-lang/ghc/ghc-8.0.2.ebuild
+++ b/dev-lang/ghc/ghc-8.0.2.ebuild
@@ -18,7 +18,7 @@ inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
inherit multilib pax-utils toolchain-funcs versionator prefix
inherit check-reqs
DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
+HOMEPAGE="https://www.haskell.org/ghc/"
# we don't have any binaries yet
arch_binaries=""
@@ -60,7 +60,7 @@ GHC_PV=${PV}
#GHC_PV=8.0.1.20161213 # uncomment only for -rc ebuilds
GHC_P=${PN}-${GHC_PV} # using ${P} is almost never correct
-SRC_URI="!binary? ( http://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
+SRC_URI="!binary? ( https://downloads.haskell.org/~ghc/${PV/_rc/-rc}/${GHC_P}-src.tar.xz )"
S="${WORKDIR}"/${GHC_P}
[[ -n $arch_binaries ]] && SRC_URI+=" !ghcbootstrap? ( $arch_binaries )"
@@ -181,7 +181,7 @@ update_SRC_URI() {
set -- $p
pn=$1 pv=$2
- SRC_URI+=" mirror://hackage/package/${pn}/${pn}-${pv}.tar.gz"
+ SRC_URI+=" https://hackage.haskell.org/package/${pn}-${pv}/${pn}-${pv}.tar.gz"
done
}
@@ -255,7 +255,7 @@ ghc_setup_cflags() {
fi
# prevent from failind building unregisterised ghc:
- # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
+ # https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
use ppc64 && append-ghc-cflags persistent compile -mminimal-toc
}