summaryrefslogtreecommitdiff
path: root/dev-lang/crystal/files/crystal-0.31.0-verbose.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/crystal/files/crystal-0.31.0-verbose.patch')
-rw-r--r--dev-lang/crystal/files/crystal-0.31.0-verbose.patch7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-lang/crystal/files/crystal-0.31.0-verbose.patch b/dev-lang/crystal/files/crystal-0.31.0-verbose.patch
new file mode 100644
index 000000000000..f381704ba0d9
--- /dev/null
+++ b/dev-lang/crystal/files/crystal-0.31.0-verbose.patch
@@ -0,0 +1,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -29,3 +29,3 @@ SOURCES := $(shell find src -name '*.cr')
+ SPEC_SOURCES := $(shell find spec -name '*.cr')
+-override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
++override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )$(if $(verbose),--verbose )
+ SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )