summaryrefslogtreecommitdiff
path: root/dev-lang/c-intercal/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/c-intercal/files')
-rw-r--r--dev-lang/c-intercal/files/c-intercal-30.0-version.patch11
-rw-r--r--dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch17
-rw-r--r--dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch13
3 files changed, 13 insertions, 28 deletions
diff --git a/dev-lang/c-intercal/files/c-intercal-30.0-version.patch b/dev-lang/c-intercal/files/c-intercal-30.0-version.patch
deleted file mode 100644
index 3fe8d026e23a..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-30.0-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- intercal-0.30-orig/configure.ac
-+++ intercal-0.30/configure.ac
-@@ -14,7 +14,7 @@
- subdir-objects no-texinfo.tex -Wall -Wno-override])
-
- dnl Information about this version of INTERCAL.
--PACKAGE_VERSION=0.29
-+PACKAGE_VERSION=0.30
-
- dnl Checks for programs.
- AC_PROG_YACC
diff --git a/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch b/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
deleted file mode 100644
index 9d46a91beceb..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/604848
-
---- intercal-0.30-orig/src/lexer.l
-+++ intercal-0.30/src/lexer.l
-@@ -38,12 +38,10 @@
- /*#undef wchar_t*/
- /*#define wchar_t unsigned char*/
-
--#ifndef yywrap
- static int yywrap(void)
- {
- return 1;
- }
--#endif /* yywrap */
-
- int iyylineno = 1;
-
diff --git a/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
new file mode 100644
index 000000000000..ff409aeb2518
--- /dev/null
+++ b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/711902
+
+--- intercal-0.31-orig/src/perpet.c
++++ intercal-0.31/src/perpet.c
+@@ -85,7 +85,7 @@
+ /* function created by yacc */
+ extern int yyparse(void);
+
+-int yydebug;
++extern int yydebug;
+
+ /* compilation options */
+ bool compile_only; /* just compile into C, don't run the linker */