summaryrefslogtreecommitdiff
path: root/dev-java/xp/xp-0.5-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xp/xp-0.5-r4.ebuild')
-rw-r--r--dev-java/xp/xp-0.5-r4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/xp/xp-0.5-r4.ebuild b/dev-java/xp/xp-0.5-r4.ebuild
new file mode 100644
index 000000000000..c39c99adaa5b
--- /dev/null
+++ b/dev-java/xp/xp-0.5-r4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="XP is an XML 1.0 parser written in Java"
+HOMEPAGE="http://www.jclark.com/xml/xp"
+SRC_URI="ftp://ftp.jclark.com/pub/xml/${PN}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-jdk-1.7-enum.patch"
+)
+
+src_prepare() {
+ default
+ java-pkg_clean
+}