summaryrefslogtreecommitdiff
path: root/dev-java/openjdk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/openjdk')
-rw-r--r--dev-java/openjdk/Manifest3
-rw-r--r--dev-java/openjdk/openjdk-11.0.3_p7-r3.ebuild239
-rw-r--r--dev-java/openjdk/openjdk-11.0.3_p7-r4.ebuild2
3 files changed, 2 insertions, 242 deletions
diff --git a/dev-java/openjdk/Manifest b/dev-java/openjdk/Manifest
index 5e06f5a878c8..e7d600f7d673 100644
--- a/dev-java/openjdk/Manifest
+++ b/dev-java/openjdk/Manifest
@@ -10,7 +10,6 @@ DIST openjdk-jaxws-8.212_p03.tar.bz2 2540937 BLAKE2B 53c2793d9071f408a3704dacc4d
DIST openjdk-jdk-8.212_p03.tar.bz2 46720739 BLAKE2B af515701052ede8b6cf828cc74f1f5938dad0874a12ed3c5c3f7b03be1f43108fce5e1820452a87e098c3469922227950f6f4fea33306f7b426487b48cc4b993 SHA512 9b3342419c82a8f243d2a7523d83b395c89629820fd99ba387991656e5754ed067877bf12b7e780368dd4bdb6eba10be09e63b1301bcbc0aa29e86e84ec394a3
DIST openjdk-langtools-8.212_p03.tar.bz2 2393112 BLAKE2B 96656795114bad1d2e5eabace5d1c6568646084421fbaa43045ce0ec8d222f1a7e8629e4b86bdd5ff8eb51e90ea1eaafab3e94f34c41932754249f17b2e447f8 SHA512 15b931432cb14cf60c73627bd70e66f6d18ff25763a7b8758109cf8746d278d6c2b5d945a9f0b948a76c0813b5f42c988a3d10ac13165ec12e0f4d9eab98f369
DIST openjdk-nashorn-8.212_p03.tar.bz2 2854888 BLAKE2B 3e5a1867d8a5db301fb3512ebdc4dea8f8226fe3308142d6f3f616795c9cee0d598a257ccd7e790ec440c966339399776d1118764dbf882a46a2daa32d81ddd5 SHA512 5c7fba1d567aa1d0602ef045b24a8624fed9ced72b3bae030ee15ea133ed2223e402cc08c996ff253c4792570da87b7713f351c84704b12556466349f6452f74
-EBUILD openjdk-11.0.3_p7-r3.ebuild 6633 BLAKE2B 544ba95a98184a8ebcc8afbed6df35bae6ebc915d85bca14cd4372a455a993870b412af3a523776b12ab098959893722679225894c3d39cbd81142701b41e85a SHA512 3f977211e70ae9cbeb4d14880e844aa93ec84ce68160a1c2a9a684ed92fc1fb4ec7ae7be3837b6549f59524420c5ad0b941efba5b5e782f7a21f3e1c9b61a13c
-EBUILD openjdk-11.0.3_p7-r4.ebuild 7389 BLAKE2B 26ef9976d264502a77c83f37bb6c1e2fbc17da768f5abfaadf83408598f8e23eec8f3f2adae63801d7972bccd72fb7b7a2f99a6aa8f9b674aa0b1eae1a1af520 SHA512 2d9aa129b5d161b5d42c07767d24910cbdf4f563f477a4b4b926229ce06b572c169f7e352c9d91f03fee06e4edcf49b5dcb67ec598202267a8a20479e41ffa0a
+EBUILD openjdk-11.0.3_p7-r4.ebuild 7394 BLAKE2B d82ea0a57aa97fb40887b7f4da9bc7a6c61b17c6bb0026eef979e9cb44937a7c253e0364c0487348d6274cd7e6f1f84d0a7a3e9ce710729992b1484b42b41531 SHA512 cfb17b2bcfff4a0d63dc4e1a180ad1b088c7d49cd1949ee0605e68342424e4d1e91468cb0c053937d535423d569d7f4164f99c05ffc1618ae996337d73c603d7
EBUILD openjdk-8.212_p03-r3.ebuild 7320 BLAKE2B dc4a418d885c1db666dee134dd5fa73a041772dac925fe7249a24531ed7e38e29c8f1f8ea4d7aa41dcea7173cebb1ef110b6ffe8cffc8bb7b0166751e13e8c2b SHA512 c6b402eadf629322aaa9207cf8ebfcacbd3bb702ee565372200b2f74be8d26b4eb41ffdfc85feb945e8dc044c7f4c5c650172fe27cb59deb32daaa95be3e1063
MISC metadata.xml 1398 BLAKE2B 7b99e080f6dc261c94314c7f7a0314ee25b48752ca494dd23d1534c5e8e3f930601262a0316ed674786c5fd960dfbc25dd6c6768cd06325ef45c0b41f920eafc SHA512 1747f484c6f784cb551f0969aab9ca1e6c42509c06b6187b72f3e16861ce3e2e71e131deb1ae6ebe2eda1c768276794cd5a0db7918eb419b9502a3c45bf78959
diff --git a/dev-java/openjdk/openjdk-11.0.3_p7-r3.ebuild b/dev-java/openjdk/openjdk-11.0.3_p7-r3.ebuild
deleted file mode 100644
index 3a4668d70da8..000000000000
--- a/dev-java/openjdk/openjdk-11.0.3_p7-r3.ebuild
+++ /dev/null
@@ -1,239 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools check-reqs flag-o-matic java-pkg-2 java-vm-2 multiprocessing pax-utils toolchain-funcs
-
-MY_PV=${PV/_p/+}
-SLOT=${MY_PV%%[.+]*}
-
-DESCRIPTION="Open source implementation of the Java programming language"
-HOMEPAGE="https://openjdk.java.net"
-SRC_URI="https://hg.${PN}.java.net/jdk-updates/jdk${SLOT}u/archive/jdk-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-
-IUSE="alsa cups debug doc examples gentoo-vm headless-awt +jbootstrap nsplugin +pch selinux source systemtap +webstart"
-
-COMMON_DEPEND="
- media-libs/freetype:2=
- media-libs/giflib:0/7
- media-libs/libpng:0=
- media-libs/lcms:2=
- sys-libs/zlib
- virtual/jpeg:0=
- systemtap? ( dev-util/systemtap )
-"
-
-# Many libs are required to build, but not to run, make is possible to remove
-# by listing conditionally in RDEPEND unconditionally in DEPEND
-RDEPEND="
- ${COMMON_DEPEND}
- >=sys-apps/baselayout-java-0.1.0-r1
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXtst
- )
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
-"
-
-DEPEND="
- ${COMMON_DEPEND}
- app-arch/zip
- media-libs/alsa-lib
- net-print/cups
- x11-base/xorg-proto
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXtst
- || (
- dev-java/openjdk-bin:${SLOT}
- dev-java/openjdk:${SLOT}
- )
-"
-
-PDEPEND="
- webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
- nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )
-"
-
-S="${WORKDIR}/jdk${SLOT}u-jdk-${MY_PV}"
-
-# The space required to build varies wildly depending on USE flags,
-# ranging from 2GB to 16GB. This function is certainly not exact but
-# should be close enough to be useful.
-openjdk_check_requirements() {
- local M
- M=2048
- M=$(( $(usex jbootstrap 2 1) * $M ))
- M=$(( $(usex debug 3 1) * $M ))
- M=$(( $(usex doc 320 0) + $(usex source 128 0) + 192 + $M ))
-
- CHECKREQS_DISK_BUILD=${M}M check-reqs_pkg_${EBUILD_PHASE}
-}
-
-pkg_pretend() {
- openjdk_check_requirements
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
-}
-
-pkg_setup() {
- openjdk_check_requirements
- java-vm-2_pkg_setup
-
- JAVA_PKG_WANT_BUILD_VM="openjdk-${SLOT} openjdk-bin-${SLOT}"
- JAVA_PKG_WANT_SOURCE="${SLOT}"
- JAVA_PKG_WANT_TARGET="${SLOT}"
-
- # The nastiness below is necessary while the gentoo-vm USE flag is
- # masked. First we call java-pkg-2_pkg_setup if it looks like the
- # flag was unmasked against one of the possible build VMs. If not,
- # we try finding one of them in their expected locations. This would
- # have been slightly less messy if openjdk-bin had been installed to
- # /opt/${PN}-${SLOT} or if there was a mechanism to install a VM env
- # file but disable it so that it would not normally be selectable.
-
- local vm
- for vm in ${JAVA_PKG_WANT_BUILD_VM}; do
- if [[ -d ${EPREFIX}/usr/lib/jvm/${vm} ]]; then
- java-pkg-2_pkg_setup
- return
- fi
- done
-
- if has_version --host-root dev-java/openjdk:${SLOT}; then
- export JDK_HOME=${EPREFIX}/usr/$(get_libdir)/openjdk-${SLOT}
- else
- if [[ ${MERGE_TYPE} != "binary" ]]; then
- JDK_HOME=$(best_version --host-root dev-java/openjdk-bin:${SLOT})
- [[ -n ${JDK_HOME} ]] || die "Build VM not found!"
- JDK_HOME=${JDK_HOME#*/}
- JDK_HOME=${EPREFIX}/opt/${JDK_HOME%-r*}
- export JDK_HOME
- fi
- fi
-}
-
-src_prepare() {
- default
- chmod +x configure || die
-}
-
-src_configure() {
- # Work around stack alignment issue, bug #647954. in case we ever have x86
- use x86 && append-flags -mincoming-stack-boundary=2
-
- # Enabling full docs appears to break doc building. If not
- # explicitly disabled, the flag will get auto-enabled if pandoc and
- # graphviz are detected. pandoc has loads of dependencies anyway.
-
- local myconf=(
- --disable-ccache
- --enable-full-docs=no
- --with-boot-jdk="${JDK_HOME}"
- --with-extra-cflags="${CFLAGS}"
- --with-extra-cxxflags="${CXXFLAGS}"
- --with-extra-ldflags="${LDFLAGS}"
- --with-giflib=system
- --with-lcms=system
- --with-libjpeg=system
- --with-libpng=system
- --with-native-debug-symbols=$(usex debug internal none)
- --with-vendor-name="Gentoo"
- --with-vendor-url="https://gentoo.org"
- --with-vendor-bug-url="https://bugs.gentoo.org"
- --with-vendor-vm-bug-url="https://bugs.openjdk.java.net"
- --with-vendor-version-string="${PV}"
- --with-version-pre=gentoo
- --with-version-string=${MY_PV%+*}
- --with-version-build=${MY_PV#*+}
- --with-zlib=system
- --enable-dtrace=$(usex systemtap yes no)
- --enable-headless-only=$(usex headless-awt yes no)
- )
-
- # PaX breaks pch, bug #601016
- if use pch && ! host-is-pax; then
- myconf+=( --enable-precompiled-headers )
- else
- myconf+=( --disable-precompiled-headers )
- fi
-
- (
- unset _JAVA_OPTIONS JAVA JAVAC XARGS
- CFLAGS= CXXFLAGS= LDFLAGS= \
- CONFIG_SITE=/dev/null \
- econf "${myconf[@]}"
- )
-}
-
-src_compile() {
- emake -j1 \
- $(usex doc docs '') \
- $(usex jbootstrap bootcycle-images product-images) \
- JOBS=$(makeopts_jobs) LOG=debug CFLAGS_WARNINGS_ARE_ERRORS= # No -Werror
-}
-
-src_install() {
- local dest="/usr/$(get_libdir)/${PN}-${SLOT}"
- local ddest="${ED}${dest#/}"
-
- cd "${S}"/build/*-release/images/jdk || die
-
- # Oracle and IcedTea have libjsoundalsa.so depending on
- # libasound.so.2 but OpenJDK only has libjsound.so. Weird.
- if ! use alsa ; then
- rm -v lib/libjsound.* || die
- fi
-
- if ! use examples ; then
- rm -vr demo/ || die
- fi
-
- if ! use source ; then
- rm -v lib/src.zip || die
- fi
-
- mv lib/security/cacerts lib/security/cacerts.orig || die
-
- dodir "${dest}"
- cp -pPR * "${ddest}" || die
-
- dosym "${EPREFIX}"/etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
-
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
- java-vm_set-pax-markings "${ddest}"
- java-vm_revdep-mask
- java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-
- if use doc ; then
- insinto /usr/share/doc/${PF}/html
- doins -r "${S}"/build/*-release/images/docs/*
- fi
-}
-
-pkg_postinst() {
- java-vm-2_pkg_postinst
-
- if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
- ewarn "recognised by the system. This will almost certainly break things."
- else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
- ewarn "will not be recognised by the system. For example, simply calling"
- ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
- ewarn "fully supports Java ${SLOT}. This JDK must therefore be invoked using its"
- ewarn "absolute location under ${EPREFIX}/usr/$(get_libdir)/${PN}-${SLOT}."
- fi
-}
diff --git a/dev-java/openjdk/openjdk-11.0.3_p7-r4.ebuild b/dev-java/openjdk/openjdk-11.0.3_p7-r4.ebuild
index ad003801a229..67e91789000b 100644
--- a/dev-java/openjdk/openjdk-11.0.3_p7-r4.ebuild
+++ b/dev-java/openjdk/openjdk-11.0.3_p7-r4.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://openjdk.java.net"
SRC_URI="https://hg.${PN}.java.net/jdk-updates/jdk${SLOT}u/archive/jdk-${MY_PV}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
IUSE="alsa cups debug doc examples gentoo-vm headless-awt javafx +jbootstrap nsplugin +pch selinux source systemtap +webstart"