summaryrefslogtreecommitdiff
path: root/dev-java/lzmajio/lzmajio-0.95-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/lzmajio/lzmajio-0.95-r2.ebuild')
-rw-r--r--dev-java/lzmajio/lzmajio-0.95-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/lzmajio/lzmajio-0.95-r2.ebuild b/dev-java/lzmajio/lzmajio-0.95-r2.ebuild
new file mode 100644
index 000000000000..419b3afc2c7d
--- /dev/null
+++ b/dev-java/lzmajio/lzmajio-0.95-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="LzmaInputStream/LzmaOutputStream interacting with underlying LZMA en-/decoders"
+HOMEPAGE="https://github.com/league/lzmajio"
+SRC_URI="https://github.com/league/${P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/lzma:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="lzma"
+JAVA_SRC_DIR="net"