summaryrefslogtreecommitdiff
path: root/dev-java/jtds
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jtds')
-rw-r--r--dev-java/jtds/Manifest3
-rw-r--r--dev-java/jtds/jtds-1.3.1.ebuild43
-rw-r--r--dev-java/jtds/metadata.xml20
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/jtds/Manifest b/dev-java/jtds/Manifest
new file mode 100644
index 000000000000..a524ee79ff0e
--- /dev/null
+++ b/dev-java/jtds/Manifest
@@ -0,0 +1,3 @@
+DIST jtds-1.3.1-src.zip 3377625 BLAKE2B 2c5ccfa4d7c6fbb1879007b5f0e9bcfd1ae1061fc68174d1679c72f3f9806433af842d5ca8e47da69acf53b8d517522f33a901adfa35867c96a63446da5269c3 SHA512 1744219a52c7167449388d774fd5e834ef551f60548569c4c54e6caefaade1d932a3879a023869d8d9ddb29ce4ab52b6d08bc4c364d5f372ff5fa96bed6d9864
+EBUILD jtds-1.3.1.ebuild 829 BLAKE2B 692867bb0c1c9f82f98d5fa30cfaee62025d6c16a2411262ef2f11fc375b20fca5d8bd5efce3e53167d0045df22a2dcc358f6d94be28e347ec31f346ecf24241 SHA512 482f2b94a427eecbfd3bccdd678635bd733379c7cd5b04ade41e12dfa5a30f7cc9f5dfa9e871936b0e74b77947bc141a75fe45d23de4509ca9cb8b75adf6adeb
+MISC metadata.xml 877 BLAKE2B fc1466a12596bb64c25bfae6c5d00d90e9541f3e01ba181224ef3c821e4312e46da4e0e1f251cce58654d71d4dd148b057bcba970ce5e9558b8238e936056bce SHA512 0a8371b9d8819206fa47ca34dae6a4ade669eabefc2b94fadb76bc4bcbd3c5d563a0dbe36860c8a90ca23d2b74f2088ed7d89864c94bd0f8f4650bd31844047c
diff --git a/dev-java/jtds/jtds-1.3.1.ebuild b/dev-java/jtds/jtds-1.3.1.ebuild
new file mode 100644
index 000000000000..fd6ec16d4026
--- /dev/null
+++ b/dev-java/jtds/jtds-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="jTDS - SQL Server and Sybase JDBC driver"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://jtds.sourceforge.net"
+LICENSE="LGPL-2.1"
+SLOT="1.3"
+KEYWORDS="amd64 x86"
+RESTRICT="test" # Needs a running server
+
+CDEPEND="dev-java/jcifs:1.1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+
+JAVA_SRC_DIR="src/main"
+JAVA_ENCODING="ISO-8859-1"
+JAVA_GENTOO_CLASSPATH="jcifs-1.1"
+
+java_prepare() {
+ java-pkg_clean
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar ${JAVA_SRC_DIR}
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc CHANGELOG README*
+}
diff --git a/dev-java/jtds/metadata.xml b/dev-java/jtds/metadata.xml
new file mode 100644
index 000000000000..816c7d4dfbca
--- /dev/null
+++ b/dev-java/jtds/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+jTDS is an open source 100% pure Java (type 4) JDBC 3.0 driver for Microsoft SQL
+Server (6.5, 7, 2000 and 2005) and Sybase (10, 11, 12). jTDS is based on the
+work of the FreeTDS project and is currently the fastest complete JDBC driver
+for SQL Server and Sybase. Starting with release 0.9 jTDS is 100% JDBC 3.0
+compatible, supporting forward-only and scrollable/updateable ResultSets,
+multiple concurrent (completely independent) Statements per Connection and
+implementing all the DatabaseMetaData and ResultSetMetaData methods.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jtds</remote-id>
+ </upstream>
+</pkgmetadata>