summaryrefslogtreecommitdiff
path: root/dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild')
-rw-r--r--dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild b/dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild
new file mode 100644
index 000000000000..a1c6f07ac18e
--- /dev/null
+++ b/dev-java/jnr-a64asm/jnr-a64asm-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jnr/jnr-a64asm/archive/refs/tags/jnr-a64asm-1.0.0.tar.gz --slot 2 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild jnr-a64asm-1.0.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.github.jnr:jnr-a64asm:1.0.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A pure-java A64 assembler"
+HOMEPAGE="http://nexus.sonatype.org/oss-repository-hosting.html/jnr-a64asm"
+SRC_URI="https://github.com/jnr/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"