summaryrefslogtreecommitdiff
path: root/dev-java/jmh-core/jmh-core-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jmh-core/jmh-core-1.4.1.ebuild')
-rw-r--r--dev-java/jmh-core/jmh-core-1.4.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-java/jmh-core/jmh-core-1.4.1.ebuild b/dev-java/jmh-core/jmh-core-1.4.1.ebuild
deleted file mode 100644
index b2ef63a5460b..000000000000
--- a/dev-java/jmh-core/jmh-core-1.4.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-# Hash of tag, download not available via ${PV}
-MY_PN="jmh"
-MY_PV="7ff584954008"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Harness for building, running, and analysing nano/micro/milli/macro benchmarks"
-HOMEPAGE="https://openjdk.java.net/projects/code-tools/jmh"
-SRC_URI="https://hg.openjdk.java.net/code-tools/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# jopt *must* be 4.6, see https://mail.openjdk.java.net/pipermail/jmh-dev/2016-October/002395.html
-CDEPEND="
- dev-java/asm:4
- dev-java/junit:4
- dev-java/commons-math:3
- dev-java/jopt-simple:4.6
- source? ( app-arch/zip )"
-
-DEPEND=">=virtual/jdk-1.7
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.7
- ${CDEPEND}"
-
-JAVA_GENTOO_CLASSPATH="asm-4,commons-math-3,jopt-simple,junit-4"
-
-S="${WORKDIR}/${MY_PN}-${MY_PV}/${PN}"