summaryrefslogtreecommitdiff
path: root/dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild')
-rw-r--r--dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild b/dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..f0c536f80c94
--- /dev/null
+++ b/dev-java/jformatstring/jformatstring-2.0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FINDBUGS_PV="3.0.1"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compile time checking for Java format strings"
+SRC_URI="mirror://sourceforge/findbugs/findbugs-${FINDBUGS_PV}-source.zip"
+HOMEPAGE="https://code.google.com/p/j-format-string"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*
+ app-arch/unzip"
+
+src_unpack() {
+ unzip -qoj "${DISTDIR}/findbugs-${FINDBUGS_PV}-source.zip" "findbugs-${FINDBUGS_PV}/lib/jFormatString.jar" || die
+ unpack ./jFormatString.jar
+}
+
+src_prepare() {
+ default
+ find -name "*.class" -delete || die
+}