summaryrefslogtreecommitdiff
path: root/dev-java/jaxen
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jaxen')
-rw-r--r--dev-java/jaxen/Manifest6
-rw-r--r--dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml200
-rw-r--r--dev-java/jaxen/jaxen-1.1.4-r1.ebuild51
-rw-r--r--dev-java/jaxen/jaxen-1.1.6.ebuild36
-rw-r--r--dev-java/jaxen/metadata.xml8
5 files changed, 301 insertions, 0 deletions
diff --git a/dev-java/jaxen/Manifest b/dev-java/jaxen/Manifest
new file mode 100644
index 000000000000..f03dd90bdd34
--- /dev/null
+++ b/dev-java/jaxen/Manifest
@@ -0,0 +1,6 @@
+AUX jaxen-1.1.4_maven1-build.xml 13148 BLAKE2B c5f6421878e732db00b2d5daede8d93cdf1d349c1dfdbb6f83a607d734dc05f0847ce5f8cc86ec1a2be5855d96dfc1a3128c0811846f4a5c7679dd60ad730c12 SHA512 2f3625a2a14066289b20e1118a87168e6cf1ce252becdccbc6f4eeefac446e528298e1e6af7d1304ff9d1d4ee8c394c2cf67f6799d3062091d53cce7ff5b1e42
+DIST jaxen-1.1.4-src.tar.gz 268493 BLAKE2B ff51cf3b6507f19549ab864fa4cd53d0b2d0c34a21a944d22feed74d58fb71c0273f5b560cc9c02aa50748f672115e77fab24a2d986508841d6a0ba4b8911690 SHA512 11c1c744af030c50579f872d8c8bf437e48ab4a01e6dd34529f2d9039c154533edaa9b5a367a866e2b57f311f1111717be300db8f80423c5492be38e0cffc031
+DIST jaxen-1.1.6.jar 409677 BLAKE2B 55e03939420c103fb5a6d323595ff0cb7653885eb9ba233fd581c5376d2ac90eecde7aa5576f602cdc459cfd9ba9e79c6bb5bfab3ed7805e717a21670a5748ee SHA512 979044fe959493eb6d66fa92b420251cd9c12414051ff6956d5835888a8999d4f337c18646c53806fc19203cef744f53b7597850cd2f695910c90df7a9725b48
+EBUILD jaxen-1.1.4-r1.ebuild 1090 BLAKE2B c28b7b787c6ea71c7d8a571196be139f1808584d79c986f634663d3aaf4d71917706f74a064c5811d9341734bdb47e02a48836379e90bc7fad5f7f4dc489052e SHA512 26f400c5aedc4449ff42ab48f503c28997e45d99cf76b8c8c18dd1378c19cf9df9c032c968faa47e7cc0a5b02410a115002a1f74ca0d1ef2b8aae186b652fbf8
+EBUILD jaxen-1.1.6.ebuild 613 BLAKE2B 7f5654f3b927954ff7511664248e6083fa7b3019e1fa893e356175a27fd40d812f8ef0470fbf9c1cff8906e87048b9d808c9d377f8c7e872662339ce821b2690 SHA512 4bb8b4f2c124f9eac8e96ce99cb32d39dd04c46e6e17b7217f8791d417ce8dc87067d611df50967a2caec67265fdb14aac9d0f28a57c4bfe88f941bd860bf91e
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
new file mode 100644
index 000000000000..efbdd2074bb2
--- /dev/null
+++ b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
@@ -0,0 +1,200 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.1.4
+ on date October 14 2012, time 0755-->
+<project default="jar" name="jaxen" basedir=".">
+ <!--Load local and user build preferences-->
+ <property file="build.properties"></property>
+ <property file="${user.home}/build.properties"></property>
+ <!--Build properties-->
+ <property name="defaulttargetdir" value="${basedir}/target"></property>
+ <property name="libdir" value="${user.home}/.maven/repository"></property>
+ <property name="classesdir" value="${basedir}/target/classes"></property>
+ <property name="testclassesdir" value="${basedir}/target/test-classes"></property>
+ <property name="testreportdir" value="${basedir}/target/test-reports"></property>
+ <property name="distdir" value="${basedir}/dist"></property>
+ <property name="javadocdir" value="${basedir}/dist/docs/api"></property>
+ <property name="final.name" value="jaxen-1.1.4"></property>
+ <property name="proxy.host" value=""></property>
+ <property name="proxy.port" value=""></property>
+ <property name="proxy.username" value=""></property>
+ <property name="proxy.password" value=""></property>
+ <path id="build.classpath">
+ <pathelement location="${libdir}/dom4j/jars/dom4j-1.6.1.jar"></pathelement>
+ <pathelement location="${libdir}/jdom/jars/jdom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar"></pathelement>
+ <pathelement location="${libdir}/xerces/jars/xercesImpl-2.6.2.jar"></pathelement>
+ <pathelement location="${libdir}/xom/jars/xom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></pathelement>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}"></equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+ <available property="Junit.present" classname="junit.framework.Test"></available>
+ <!--Test if user defined a proxy-->
+ <condition property="useProxy">
+ <and>
+ <isset property="proxy.host"></isset>
+ <not>
+ <equals trim="true" arg2="" arg1="${proxy.host}"></equals>
+ </not>
+ </and>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}"></mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/main"></pathelement>
+ </src>
+ <classpath refid="build.classpath"></classpath>
+ </javac>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile,test">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}"></delete>
+ <delete dir="${distdir}"></delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist"></mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar"></fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*"></fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures."></fail>
+ </target>
+ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
+ <mkdir dir="${testreportdir}"></mkdir>
+ <junit dir="${basedir}" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value="."></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="false" type="plain"></formatter>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${testclassesdir}"></pathelement>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="${basedir}/src/java/test">
+ <include name="**/*Test.java"></include>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
+ <mkdir dir="${testclassesdir}"></mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/test"></pathelement>
+ </src>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ </javac>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="get-deps">
+ <mkdir dir="${javadocdir}"></mkdir>
+ <tstamp>
+ <format pattern="2001-yyyy" property="year"></format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; Codehaus. All Rights Reserved."></property>
+ <property name="title" value="jaxen 1.1.4 API"></property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java/main" packagenames="org.jaxen.*">
+ <classpath>
+ <path refid="build.classpath"></path>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-dep-dom4j.jar" description="o Download the dependency : dom4j.jar" unless="dom4j.jar" depends="init,setProxy,noProxy,get-custom-dep-dom4j.jar">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/dom4j/jars/dom4j-1.6.1.jar"></get>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//dom4j/jars/dom4j-1.6.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-dom4j.jar" if="dom4j.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="${dom4j.jar}"></get>
+ </target>
+ <target name="get-dep-jdom.jar" description="o Download the dependency : jdom.jar" unless="jdom.jar" depends="init,setProxy,noProxy,get-custom-dep-jdom.jar">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/jdom/jars/jdom-1.0.jar"></get>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//jdom/jars/jdom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-jdom.jar" if="jdom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${jdom.jar}"></get>
+ </target>
+ <target name="get-dep-xml-apis.jar" description="o Download the dependency : xml-apis.jar" unless="xml-apis.jar" depends="init,setProxy,noProxy,get-custom-dep-xml-apis.jar">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ </target>
+ <target name="get-custom-dep-xml-apis.jar" if="xml-apis.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="${xml-apis.jar}"></get>
+ </target>
+ <target name="get-dep-xercesImpl.jar" description="o Download the dependency : xercesImpl.jar" unless="xercesImpl.jar" depends="init,setProxy,noProxy,get-custom-dep-xercesImpl.jar">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xerces/jars/xercesImpl-2.6.2.jar"></get>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xerces/jars/xercesImpl-2.6.2.jar"></get>
+ </target>
+ <target name="get-custom-dep-xercesImpl.jar" if="xercesImpl.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="${xercesImpl.jar}"></get>
+ </target>
+ <target name="get-dep-xom.jar" description="o Download the dependency : xom.jar" unless="xom.jar" depends="init,setProxy,noProxy,get-custom-dep-xom.jar">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xom/jars/xom-1.0.jar"></get>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xom/jars/xom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-xom.jar" if="xom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${xom.jar}"></get>
+ </target>
+ <target name="get-dep-maven-cobertura-plugin.jar" description="o Download the dependency : maven-cobertura-plugin.jar" unless="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-cobertura-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-cobertura-plugin.jar" if="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="${maven-cobertura-plugin.jar}"></get>
+ </target>
+ <target name="get-dep-maven-findbugs-plugin.jar" description="o Download the dependency : maven-findbugs-plugin.jar" unless="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-findbugs-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-findbugs-plugin.jar" if="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="${maven-findbugs-plugin.jar}"></get>
+ </target>
+ <target name="get-deps" unless="noget"></target>
+ <target name="setProxy" if="useProxy" depends="init">
+ <!--Proxy settings works only with a JDK 1.2 and higher.-->
+ <echo>Proxy used :</echo>
+ <echo>Proxy host [${proxy.host}]</echo>
+ <echo>Proxy port [${proxy.port}]</echo>
+ <echo>Proxy user [${proxy.username}]</echo>
+ <setproxy proxyuser="${proxy.username}" proxyport="${proxy.port}" proxypassword="${proxy.password}" proxyhost="${proxy.host}"></setproxy>
+ </target>
+ <target name="noProxy" unless="useProxy" depends="init">
+ <echo>Proxy not used.</echo>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar"></get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
+ </target>
+</project>
diff --git a/dev-java/jaxen/jaxen-1.1.4-r1.ebuild b/dev-java/jaxen/jaxen-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..c9891f11b423
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.4-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="http://jaxen.org"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
+
+LICENSE="JDOM"
+SLOT="1.1"
+KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="
+ dev-java/xom:0
+ dev-java/jdom:0
+ dev-java/dom4j:1"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.4"
+
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-java/ant-junit:0 )
+ >=virtual/jdk-1.4"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="dom4j-1,jdom,xom"
+EANT_TEST_EXTRA_ARGS="-DJunit.present=true"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven1-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar"
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples src/java/samples
+ use source && java-pkg_dosrc src/java/main/*
+}
diff --git a/dev-java/jaxen/jaxen-1.1.6.ebuild b/dev-java/jaxen/jaxen-1.1.6.ebuild
new file mode 100644
index 000000000000..77b073b118a4
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://repo1.maven.org/maven2/${PN}/${PN}/${PV}/${P}-sources.jar -> ${P}.jar"
+
+LICENSE="JDOM"
+SLOT="1.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-java/dom4j:1
+ dev-java/jdom:0
+ dev-java/xom:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="
+ xom
+ jdom
+ dom4j-1
+"
diff --git a/dev-java/jaxen/metadata.xml b/dev-java/jaxen/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/jaxen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>