summaryrefslogtreecommitdiff
path: root/dev-java/java-config/java-config-2.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/java-config/java-config-2.3.2.ebuild')
-rw-r--r--dev-java/java-config/java-config-2.3.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-java/java-config/java-config-2.3.2.ebuild b/dev-java/java-config/java-config-2.3.2.ebuild
index adc444cdbd70..001b3d072062 100644
--- a/dev-java/java-config/java-config-2.3.2.ebuild
+++ b/dev-java/java-config/java-config-2.3.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
# jython depends on java-config, so don't add it or things will break
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 prefix
@@ -27,6 +27,8 @@ RDEPEND="
sys-apps/portage[${PYTHON_USEDEP}]
"
+PATCHES=( "${FILESDIR}/2.3.2-fix-deprecated-test-methods.patch" )
+
python_configure_all() {
# setup.py fails to update this file
eprefixify src/launcher.bash