summaryrefslogtreecommitdiff
path: root/dev-java/commons-pool/commons-pool-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-pool/commons-pool-1.6.ebuild')
-rw-r--r--dev-java/commons-pool/commons-pool-1.6.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-java/commons-pool/commons-pool-1.6.ebuild b/dev-java/commons-pool/commons-pool-1.6.ebuild
deleted file mode 100644
index ad7179cfd030..000000000000
--- a/dev-java/commons-pool/commons-pool-1.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Provides general purpose object pooling API"
-HOMEPAGE="http://commons.apache.org/pool/"
-SRC_URI="mirror://apache/commons/pool/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-
-RDEPEND=">=virtual/jre-1.5"
-DEPEND=">=virtual/jdk-1.5
- test? (
- dev-java/ant-junit
- dev-java/junit:0
- )"
-
-S="${WORKDIR}/${P}-src"
-
-EANT_BUILD_TARGET="build-jar"
-
-src_test() {
- ANT_TASKS="ant-junit" eant -Dclasspath="$(java-pkg_getjars junit)" test
-}
-
-src_install() {
- java-pkg_newjar dist/${P}-SNAPSHOT.jar
- dodoc README.txt RELEASE-NOTES.txt
-
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/org
-}