summaryrefslogtreecommitdiff
path: root/dev-java/commons-net
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/Manifest6
-rw-r--r--dev-java/commons-net/commons-net-3.2.ebuild40
-rw-r--r--dev-java/commons-net/files/commons-net-3.2-build.xml285
-rw-r--r--dev-java/commons-net/metadata.xml8
4 files changed, 339 insertions, 0 deletions
diff --git a/dev-java/commons-net/Manifest b/dev-java/commons-net/Manifest
new file mode 100644
index 000000000000..2e51f90a90dd
--- /dev/null
+++ b/dev-java/commons-net/Manifest
@@ -0,0 +1,6 @@
+AUX commons-net-3.2-build.xml 12390 SHA256 e4633c2bda2bfbe65780e261644eef8410cdc1edd2a7373cb78344a21796acda SHA512 e4784b083ce86b5a22d5bfba0b0d71d811abf55f8375b9982f5ac1b11bb93f4be15ec0ff4bcb8cac58681a68a03cd6b598c998251097e9bf634674712887bdbe WHIRLPOOL 77c848804f0cb1ab1b76358fb82fcc5dd3e3595e64c7773798015aeb814e2487b0260cc02dfdd9efc877050f443c66d498600d99d11fbe98a98751898ebf3302
+DIST commons-net-3.2-src.tar.gz 378351 SHA256 f9fd207a28dc357a6a515c69fb83009836b7426d6c25095d70148a6cea7d1df1 SHA512 2152b0c524320702c336b21308bb8166e00487938430b83e08d65b836ab775c372c9251957c674e0bccff6815fc3ed3bdb7113a0d2a140c53f64c2f557eef2ba WHIRLPOOL 45b80205a519795652dc6708c85b1ebe52172e9c8ffe7e01a581cd6e9ebfb4a57cdb43bba30a6b25720c72c4bbce6eda8892fe272baad6b120d6231a05c41bf2
+EBUILD commons-net-3.2.ebuild 1270 SHA256 bb881e6cfc33d9134cda04c5e22777f98f2079bdac93a3790966378264cde474 SHA512 86cb4cbc2c57a8280af40b66a3037206d31100cb48f5c9cf4b1889dfa6de2d624007f2a4581e3a266cbab878e7cf83ca0585a338267690e3206279c732fa75a6 WHIRLPOOL a5a5b84bf9af091a488699a00d91aa26517701c4ff093f8e337529a368dea77a88d4a7345d35d000c05a96493167d463f5fd379a17abd7b79dda3b770043796b
+MISC ChangeLog 3085 SHA256 9339114cc47e295abb289a5bada182291dec4a7ce5c8f6c64f5c9468fbbe4122 SHA512 58f4507113b3a25acc0240e5478687e49c767140dde1f9786f495a92be5ec79aca17a1e0daa86a18f545ffe16ffdb18f1316c3547aaf9974333c06961f57478b WHIRLPOOL e91895b0660554ee454726f60cd99b6c368225393d19f4ef8d24446db20bce076a48fc4785f2c92c32f406edf20a07889efdf2cfc8803c22817033011807ff24
+MISC ChangeLog-2015 7083 SHA256 458630c9d89f63a83c2619275528608e2f42f0038712ea31d8584b78c251e526 SHA512 c2ac2c0c4e313645c69f90b319374dae40c33cf829d5c650fb3dae42b4f140669873fd3c1681dd334e733b23f2e22ceaddd4a4dd97faa1e93d8e6c8548995ebc WHIRLPOOL 3b27acfe7db1847a1ccce25593b812a212df7b6535e8d133da970f29a2e5fbf009d617871a9f972a5916a8ab93f982f70a2692745a70adc490ef535db02aeab8
+MISC metadata.xml 232 SHA256 0c8d91b3d514ac42d0eaca567346ab909c0f947049c85c25a380ec2400f1b3fb SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893 WHIRLPOOL 3a1a6d054edc9177d85ca868f9b0a6e84ee51bab4fbdbb9b1ead1a03874036bcc3f96e903fb751dc4d29fdb7d6b5f3d8dbe7b042fc697c887e23f41cc9c8c4ac
diff --git a/dev-java/commons-net/commons-net-3.2.ebuild b/dev-java/commons-net/commons-net-3.2.ebuild
new file mode 100644
index 000000000000..31c7dfd4180f
--- /dev/null
+++ b/dev-java/commons-net/commons-net-3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
+RESTRICT="test"
+JAVA_PKG_IUSE="doc examples source" # test
+
+inherit eutils java-pkg-2 java-ant-2 java-osgi
+
+MY_P="${P}-src"
+
+DESCRIPTION="Java library emulating the client side of many basic Internet protocols"
+HOMEPAGE="http://commons.apache.org/net/"
+SRC_URI="mirror://apache/commons/net/source/${MY_P}.tar.gz"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+ sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
+ sed -i 's/manifest=".*MANIFEST.MF"//g' build.xml || die
+ sed -i '/name="Main-Class"/d' build.xml || die
+}
+
+src_install() {
+ java-osgi_newjar target/${P}.jar ${P} ${P} "Export-Package: ${P}"
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use examples && java-pkg_doexamples src/main/java/examples
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/commons-net/files/commons-net-3.2-build.xml b/dev-java/commons-net/files/commons-net-3.2-build.xml
new file mode 100644
index 000000000000..72cdd404df11
--- /dev/null
+++ b/dev-java/commons-net/files/commons-net-3.2-build.xml
@@ -0,0 +1,285 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/29/13 3:17 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-net-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-net-3.2"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*FunctionalTest.java"/>
+ <exclude name="**/*POP3*.java"/>
+ <exclude name="**/TestSetupParameters.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*FunctionalTest.java"/>
+ <exclude name="**/*POP3*.java"/>
+ <exclude name="**/TestSetupParameters.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ <link href="http://download.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="/var/tmp/portage/dev-java/commons-net-3.2/work/commons-net-3.2-src/target/osgi/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.10"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.10/junit-4.10.jar"
+ dest="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/commons-net/metadata.xml b/dev-java/commons-net/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/commons-net/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>