summaryrefslogtreecommitdiff
path: root/dev-java/commons-codec
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-codec')
-rw-r--r--dev-java/commons-codec/Manifest5
-rw-r--r--dev-java/commons-codec/commons-codec-1.11.ebuild54
-rw-r--r--dev-java/commons-codec/commons-codec-1.15.ebuild50
-rw-r--r--dev-java/commons-codec/files/commons-codec-1.11-build.xml200
4 files changed, 52 insertions, 257 deletions
diff --git a/dev-java/commons-codec/Manifest b/dev-java/commons-codec/Manifest
index c295d97ddd6a..2f933ba17f6e 100644
--- a/dev-java/commons-codec/Manifest
+++ b/dev-java/commons-codec/Manifest
@@ -1,6 +1,5 @@
-AUX commons-codec-1.11-build.xml 8949 BLAKE2B f1a5dfadeebbc183c075d96a8769218e98745936b45d38de1d0da8034a052ca99c3def82c2360857849ba7daefa1bf5d7aae1288ec71505de7154b0ab9e87aef SHA512 fc22470e625e7405308d2a21f0dbdf4bf565cc8db623bb3c4dba08d55da3a0884bc3da744cd029716af2ba51d708d0ed309f7c6a21a7df6f0e5027d5c6f646a5
-DIST commons-codec-1.11.tar.gz 369538 BLAKE2B 6b77cb3c69c81a9684b298ac5233b788d6651ecc96b70ac7fda9face5af5a60970c5bb2531fd285d20dce7732829f7470b9e4941d63025faf47247410f1ffba2 SHA512 b3159308f28b2fc50208421412d8cc81f439cc07dc3d071df7b50f2d862aab65b3d20bc8eb2906367a05ecf5138c56b5f12c6cf9c224def8b8286fe12ac5346f
+DIST commons-codec-1.15.tar.gz 423639 BLAKE2B 5d9d3dd44fda7eee77048eaa1e28f54f9baff7ad276f7e718f4a4d6c5b26605914809db538e9832bf06b1468a65432645ef9de74aec9f9af9973668a82bd996f SHA512 dcf0b86f269a96362dca5b36b9e764a07e390634804b359d4dbd1a0c50bfcc9f778e3797f196e1f553d76dd25b3c6fd016f0ffbbca856fa6c88d3d55791889ce
DIST commons-codec-1.7-src.tar.gz 291251 BLAKE2B b8fecdb9b88a21ceb3106a13332493617ecd2c8064c84a1514dec1c1c254e18116ff4926f7445bef4171000ba77da411efd6a93fe80a4795e887832035373e10 SHA512 31358283ac2827cb05486b8ff1512242153f61deb086f7fe145ee3ca38d96e43fba080a1e89a3b8cd44d09761015ff4dbe5226d29b7f9fcd59e68ca7701b28d6
-EBUILD commons-codec-1.11.ebuild 1034 BLAKE2B 075abe16652088856f9937a3cda1f729b43ff4c034352946bc7f51c8ecdae592282540a1ce051adb453399979174da6630ecfdd035f0c42c0d27e1455436a0ba SHA512 74b6d629ac8bc566e7968c3e8321d2d3a558a3a4680b50aa24a2e9e402cf1ff9727595cac87a2c88cb087989e45f6d7e9309f0e051804d8b52347795ffd68bf8
+EBUILD commons-codec-1.15.ebuild 1368 BLAKE2B 35f84a9e9d3d92f6d9ca6c57060eba3f64881b9b366004e6360f66851ba3439f5473f0703a1ebab16f4ab0030a40e217bd6305177f16380a95b072e38c32c49e SHA512 87cca5998d46ab126a72a015320374f972bb848f1c8e364aa0b99f4b0365e934768f6bf42010a4768e889ece41c3c9012e2d331829c2ca130874695f50df0faf
EBUILD commons-codec-1.7.ebuild 908 BLAKE2B 54d95f6e45fb34815077188bd9ba7b0370d565ab9a2175715e8e90f2b0d3fffcdb4d0fbe547b68bea1e70e996716bf7187dd06dc6510e5873b0a1309aaa08ec5 SHA512 8f0fd884b856b8c1796fcb6c905b70869fee94d753f442f94531045fa39f4f32ff30dc9aadbdba24135139b59c9bc6e5b6d618b335563149e22e7ee05d6e6c8e
MISC metadata.xml 1360 BLAKE2B 5e996a35877486521352b61fdb44872970caab9497267c9d95d1364bd299838486f1853b46f35ec140259d33e7158bca7224488f21c388caa4fa9e7a153006bb SHA512 d16f70860d4880e50d25e6297823fb71955c147eedd115ca7eda0a0bf6c4cbc6121bf8b12062241192facd4583f10df56a838c84940b5914f75d13f10c96e9ae
diff --git a/dev-java/commons-codec/commons-codec-1.11.ebuild b/dev-java/commons-codec/commons-codec-1.11.ebuild
deleted file mode 100644
index 6fd721a8942c..000000000000
--- a/dev-java/commons-codec/commons-codec-1.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Implementations of common encoders and decoders in Java"
-HOMEPAGE="https://commons.apache.org/codec"
-SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=virtual/jre-1.6"
-
-DEPEND="
- >=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_ANT_ENCODING="ISO-8859-1"
-EANT_TEST_GENTOO_CLASSPATH="junit-4"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-RESTRICT="test"
-
-DOCS=( RELEASE-NOTES.txt NOTICE.txt )
-
-src_prepare() {
- cp "${FILESDIR}/${P}-build.xml" "${S}/build.xml" || die
- default
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar "target/${P}.jar"
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/commons-codec/commons-codec-1.15.ebuild b/dev-java/commons-codec/commons-codec-1.15.ebuild
new file mode 100644
index 000000000000..a8a171d01424
--- /dev/null
+++ b/dev-java/commons-codec/commons-codec-1.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom commons-codec-1.15-src/pom.xml --download-uri https://apache.osuosl.org/commons/codec/source/commons-codec-1.15-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-codec-1.15.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-codec:commons-codec:1.15"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Implementations of common encoders and decoders in Java"
+HOMEPAGE="https://commons.apache.org/proper/commons-codec/"
+SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+# Compile dependencies
+# POM: ${P}-src/pom.xml
+# test? junit:junit:4.13 -> >=dev-java/junit-4.13.1:4
+# test? org.apache.commons:commons-lang3:3.8 -> >=dev-java/commons-lang-3.11:3.6
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/commons-lang-3.11:3.6
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS=(
+ "src/main/resources"
+)
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4,commons-lang-3.6"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)
diff --git a/dev-java/commons-codec/files/commons-codec-1.11-build.xml b/dev-java/commons-codec/files/commons-codec-1.11-build.xml
deleted file mode 100644
index 251268136bf8..000000000000
--- a/dev-java/commons-codec/files/commons-codec-1.11-build.xml
+++ /dev/null
@@ -1,200 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/27/18 9:10 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-codec-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-codec-1.11"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value="."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.12/junit-4.12.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/commons/commons-lang3/3.5/commons-lang3-3.5.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*AbstractTest.java"/>
- <exclude name="**/*PerformanceTest.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*AbstractTest.java"/>
- <exclude name="**/*PerformanceTest.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="UTF-8"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- docencoding="UTF-8"
- source="1.6"
- linksource="true"
- breakiterator="false">
- <link href="http://docs.oracle.com/javase/7/docs/api/"/>
- <link href="http://docs.oracle.com/javaee/6/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <!--
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="/var/tmp/portage/dev-java/commons-codec-1.11/work/commons-codec-1.11-src/target/osgi/MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class"/>
- </manifest>
- </jar>
- </target>
- -->
-
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
-</project>