summaryrefslogtreecommitdiff
path: root/dev-java/bcel/bcel-6.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/bcel/bcel-6.5.0.ebuild')
-rw-r--r--dev-java/bcel/bcel-6.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/bcel/bcel-6.5.0.ebuild b/dev-java/bcel/bcel-6.5.0.ebuild
new file mode 100644
index 000000000000..a16085388107
--- /dev/null
+++ b/dev-java/bcel/bcel-6.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir bcel-6.5.0-src --pom pom.xml --download-uri https://ftp.wayne.edu/apache//commons/bcel/source/bcel-6.5.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" --ebuild bcel-6.5.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.bcel:bcel:6.5.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Bytecode Engineering Library"
+HOMEPAGE="https://commons.apache.org/proper/commons-bcel"
+SRC_URI="mirror://apache/commons/${PN}/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_SRC_DIR="src/main/java"