summaryrefslogtreecommitdiff
path: root/dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild')
-rw-r--r--dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild b/dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild
new file mode 100644
index 000000000000..8d688871e389
--- /dev/null
+++ b/dev-haskell/yesod-persistent/yesod-persistent-1.6.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Some helpers for using Persistent from Yesod"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ >=dev-haskell/persistent-2.8:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-0.4.5:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hspec
+ >=dev-haskell/persistent-sqlite-2.8
+ dev-haskell/wai-extra )
+"