summaryrefslogtreecommitdiff
path: root/dev-haskell/yesod-auth
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yesod-auth')
-rw-r--r--dev-haskell/yesod-auth/Manifest4
-rw-r--r--dev-haskell/yesod-auth/metadata.xml14
-rw-r--r--dev-haskell/yesod-auth/yesod-auth-1.6.10.3.ebuild61
3 files changed, 71 insertions, 8 deletions
diff --git a/dev-haskell/yesod-auth/Manifest b/dev-haskell/yesod-auth/Manifest
index ac247104bbae..4d7d943d9012 100644
--- a/dev-haskell/yesod-auth/Manifest
+++ b/dev-haskell/yesod-auth/Manifest
@@ -1,3 +1,5 @@
+DIST yesod-auth-1.6.10.3.tar.gz 53373 BLAKE2B 7bde89851609099b6a8760d218706f37dd22c48ac750fc0f1bfbdd1db5c253ce5c7868eee94459320033712a27decfa59e4c158024daaf622c3d21e72e209ca3 SHA512 82b490db8424d6e340c4c19b9760e07c78a7906540dada160afd8f3de43f6767f04968753b0c218f0c53c8ddf4ff0ed33f458a770100edd8ab6c7582016662a2
DIST yesod-auth-1.6.9.tar.gz 52717 BLAKE2B 0b84d830effe84ecf5f4a5bdbaed31eb746b7af32ba39c753e0c40cf9d4a1bb4efb4fc7b4a25620acd69853ae878ff0c0937a1cd9c68c2ce06dba4d0b90ff67f SHA512 071f5c3b01f70d4cf7f9516d97bdf352a6fc20f9191c6a46bccacf84f7e245e8076ff1881fa6e64c3929d300a0361b5ed1bf67c670544e2c2eca07b8aa3e24c0
+EBUILD yesod-auth-1.6.10.3.ebuild 2007 BLAKE2B 1fcf43f0b00bc866e2728106a103af3654bfafb122ee0697b3ab3c0c55b21914ea3edec7b9fda1eee2d9943b8d4f1f7b8c871add3666d0c4b7b257dc02fe79c4 SHA512 22e4a1b2b059130c4420630ff06c13a8b209bd35861a5b92f8ca57dee237da53ec607060f3aed340a7f4f8d088e2f0f4f0687331baaa834ebfe978ef17786646
EBUILD yesod-auth-1.6.9.ebuild 2070 BLAKE2B cf36741ec2f59bbaa8d941d308d18fadb436074669830c8f2d721e865648bf88d139deafa6bbe7c27cc4a3c828d06989db2ed35d15781548f98414e35cf058a4 SHA512 55291e17a2af70cd93423aa2decf32d81efa3719604da3ee0988b3ba93e4919dfff563ee0a208cd108b44ec62f49d36b256bb421695405de36b15b6cc36b02ef
-MISC metadata.xml 355 BLAKE2B c07376d8d8b6b41dc9406096a04cb1ec3e6bd2c21d967c8886827ad11c85c775994f666b2ea18a4f88e4634f5defab441d437646401e638c91195114fa8c453f SHA512 3bd9eadb5c0b356c64299ccc002e26152bdfaa7d9da927a88251da128d139fb910dbc89f90f6ee0f0a50421dce9790a0437d84800c63d512167a90544b6d4c91
+MISC metadata.xml 343 BLAKE2B b1675530219e1813b54b54740eda637be34085fcd98189c6176b9ad85e46a1a6ad81da6f7c176413eee4425f6da5de4e4b9249a5f1a253839d337d3df046186c SHA512 e036edf030d71b3e3105c02110df2fb6b7ce3aaae0176d0d9f06e6655add8f800ea8f5a33818885dfac3cf108178669d1decbcb9c18458deb14315c2ad5fa23e
diff --git a/dev-haskell/yesod-auth/metadata.xml b/dev-haskell/yesod-auth/metadata.xml
index 5aa9588fd80e..f221cc552016 100644
--- a/dev-haskell/yesod-auth/metadata.xml
+++ b/dev-haskell/yesod-auth/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
-<use>
- <flag name="network-uri">Get Network.URI from the network-uri package</flag>
-</use>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="network-uri">Get Network.URI from the network-uri package</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-haskell/yesod-auth/yesod-auth-1.6.10.3.ebuild b/dev-haskell/yesod-auth/yesod-auth-1.6.10.3.ebuild
new file mode 100644
index 000000000000..cb40fc4a8dcf
--- /dev/null
+++ b/dev-haskell/yesod-auth/yesod-auth-1.6.10.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication for Yesod"
+HOMEPAGE="https://www.yesodweb.com/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/authenticate-1.3.4:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/email-validate-1.0:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/http-client-0.5:=[profile?]
+ dev-haskell/http-client-tls:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/nonce-1.0.2:=[profile?] <dev-haskell/nonce-1.1:=[profile?]
+ >=dev-haskell/persistent-2.8:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.4:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.6:=[profile?] <dev-haskell/yesod-form-1.8:=[profile?]
+ >=dev-haskell/yesod-persistent-1.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network-uri
+}