summaryrefslogtreecommitdiff
path: root/dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild')
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild
new file mode 100644
index 000000000000..b690a7cba4ef
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="https://github.com/yesodweb/haskell-xss-sanitize#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2 )
+"