summaryrefslogtreecommitdiff
path: root/dev-haskell/x11/x11-1.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x11/x11-1.10-r1.ebuild')
-rw-r--r--dev-haskell/x11/x11-1.10-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/x11/x11-1.10-r1.ebuild b/dev-haskell/x11/x11-1.10-r1.ebuild
new file mode 100644
index 000000000000..a9792bfb0016
--- /dev/null
+++ b/dev-haskell/x11/x11-1.10-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags:-pedantic
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/xmonad/X11"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+# remember to add libXScrnSaver manually on bumps, or src_configure will fail.
+RDEPEND=">=dev-haskell/data-default-class-0.1:=[profile?] <dev-haskell/data-default-class-0.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-pedantic
+}