summaryrefslogtreecommitdiff
path: root/dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild')
-rw-r--r--dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild b/dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild
new file mode 100644
index 000000000000..809afcd871ee
--- /dev/null
+++ b/dev-haskell/wxdirect/wxdirect-0.92.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+WX_GTK_VER="3.0"
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="helper tool for building wxHaskell"
+HOMEPAGE="https://wiki.haskell.org/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/parsec-2.1.0:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/strict:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_prepare() {
+ sed -e "s@executable wxdirect@executable wxdirect-${WX_GTK_VER}@" \
+ -i "${S}/${PN}.cabal" \
+ || die "Could not change ${PN}.cabal for wxdirect slot ${WX_GTK_VER}"
+}