summaryrefslogtreecommitdiff
path: root/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild')
-rw-r--r--dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild b/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild
new file mode 100644
index 000000000000..69598288c555
--- /dev/null
+++ b/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A HUnit/hspec assertion library to verify that an expression does not typecheck"
+HOMEPAGE="https://github.com/CRogers/should-not-typecheck"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hunit-1.2:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hspec-2.1
+ >=dev-haskell/hspec-expectations-0.6 )
+"