summaryrefslogtreecommitdiff
path: root/dev-haskell/semirings/semirings-0.5.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/semirings/semirings-0.5.4.ebuild')
-rw-r--r--dev-haskell/semirings/semirings-0.5.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/semirings/semirings-0.5.4.ebuild b/dev-haskell/semirings/semirings-0.5.4.ebuild
new file mode 100644
index 000000000000..37ae6599ef4c
--- /dev/null
+++ b/dev-haskell/semirings/semirings-0.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="two monoids as one, in holy haskimony"
+HOMEPAGE="https://github.com/chessai/semirings"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+containers +hashable +unordered-containers"
+
+RDEPEND="dev-haskell/base-compat-batteries:=[profile?]
+ >=dev-lang/ghc-7.10.1:=[gmp]
+ hashable? ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ unordered-containers? ( >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag containers containers) \
+ $(cabal_flag hashable hashable) \
+ $(cabal_flag unordered-containers unordered-containers)
+}