summaryrefslogtreecommitdiff
path: root/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild')
-rw-r--r--dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild b/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild
new file mode 100644
index 000000000000..f554a29f8648
--- /dev/null
+++ b/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +newbase,+splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Replaces/enhances \"Text.Regex\""
+HOMEPAGE="https://wiki.haskell.org/Regular_expressions"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
+ >=dev-haskell/regex-posix-0.96:=[profile?] <dev-haskell/regex-posix-0.97:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase \
+ --flag=splitbase
+}