summaryrefslogtreecommitdiff
path: root/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild')
-rw-r--r--dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
index 2e51afb3c933..efe655a7cf3b 100644
--- a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
+++ b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.4.9999
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +newbase,+splitbase
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Unicode Support version of Text.Regex, using regex-tdfa"
-HOMEPAGE="https://hub.darcs.net/shelarcy/regex-compat-tdfa"
+HOMEPAGE="http://hub.darcs.net/shelarcy/regex-compat-tdfa"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -19,8 +20,14 @@ IUSE=""
RDEPEND=">=dev-haskell/regex-base-0.93:=[profile?]
>=dev-haskell/regex-tdfa-1.1.0:=[profile?]
- >=dev-lang/ghc-6.10.4:=
+ >=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
+ >=dev-haskell/cabal-1.6
"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase \
+ --flag=splitbase
+}