summaryrefslogtreecommitdiff
path: root/dev-haskell/reflection/reflection-2.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/reflection/reflection-2.1.6.ebuild')
-rw-r--r--dev-haskell/reflection/reflection-2.1.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/reflection/reflection-2.1.6.ebuild b/dev-haskell/reflection/reflection-2.1.6.ebuild
new file mode 100644
index 000000000000..e869c96dbe2a
--- /dev/null
+++ b/dev-haskell/reflection/reflection-2.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -slow,+template-haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Reifies arbitrary terms into types that can be reflected back into terms"
+HOMEPAGE="https://github.com/ekmett/reflection"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-slow \
+ --flag=template-haskell
+}