summaryrefslogtreecommitdiff
path: root/dev-haskell/quickcheck/quickcheck-2.13.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.13.2.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.13.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.13.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.13.2.ebuild
deleted file mode 100644
index b22abf4396ab..000000000000
--- a/dev-haskell/quickcheck/quickcheck-2.13.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: +base4,-base3,templatehaskell:template-haskell
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="QuickCheck"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Automatic testing of Haskell programs"
-HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="2/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="+template-haskell"
-
-RDEPEND=">=dev-haskell/random-1.0.1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
- >=dev-haskell/splitmix-0.0.2:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-base3 \
- --flag=base4 \
- $(cabal_flag template-haskell templatehaskell)
-}