summaryrefslogtreecommitdiff
path: root/dev-haskell/psqueue
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/psqueue')
-rw-r--r--dev-haskell/psqueue/Manifest3
-rw-r--r--dev-haskell/psqueue/metadata.xml17
-rw-r--r--dev-haskell/psqueue/psqueue-1.1.0.1.ebuild36
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-haskell/psqueue/Manifest b/dev-haskell/psqueue/Manifest
deleted file mode 100644
index 891e704da5c3..000000000000
--- a/dev-haskell/psqueue/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST PSQueue-1.1.0.1.tar.gz 6408 BLAKE2B 5852064aabcea6e9495234cf16d4292878ed5b645fa822aaafb5d1bc869ba2fc30ce83ef4b5fa009faae4616b814cc776f796b38f51bae877324194755ab5bcb SHA512 76d5cd09d7955c4d7500b7e68fd4776b84d5cbbcc6eb1a101549119e11fdd8a452bc87cb473eef37655a18f5a5e616d126e020edb907901feae77a0b10b86eb9
-EBUILD psqueue-1.1.0.1.ebuild 682 BLAKE2B 936ff4ed49d9f01fe4175abbfc445e0b3c946fd6d4a2ebf8698dd1d3107f061d173e8979224a00c2ddc55f71ed855de229b0b12eb2807cdbfbf236440bf7cb24 SHA512 963c997785967e0a21fff3033091692761e83e094e37965559554f33393c68b1967797e2ccf4cba553872b8192637a7b220688ba39e812325392f58eabef91a3
-MISC metadata.xml 692 BLAKE2B 8edcf33a5bca4e8bd104379b812fbe41222ec25846ec243da52d2da461198ff8da9cb9015f8ae3e912f134fe724abca1c769e27b374e5e7da05b5962858a0d6f SHA512 e51e257d0f987c9305cf1abe69dac87b5d466fc5ee2b00360176d83bb5d39f50e2a09af31b5c2e3eddeb99734910c7c39afbcb87d36a890fe007840694c3c220
diff --git a/dev-haskell/psqueue/metadata.xml b/dev-haskell/psqueue/metadata.xml
deleted file mode 100644
index 8d1d3cb246f9..000000000000
--- a/dev-haskell/psqueue/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- A /priority search queue/ efficiently supports the
- opperations of both a search tree and a priority queue. A
- 'Binding' is a product of a key and a priority. Bindings
- can be inserted, deleted, modified and queried in
- logarithmic time, and the binding with the least priority
- can be retrieved in constant time. A queue can be built
- from a list of bindings, sorted by keys, in linear time.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/psqueue/psqueue-1.1.0.1.ebuild b/dev-haskell/psqueue/psqueue-1.1.0.1.ebuild
deleted file mode 100644
index acc11464c422..000000000000
--- a/dev-haskell/psqueue/psqueue-1.1.0.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-MY_PN="PSQueue"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Priority Search Queue"
-HOMEPAGE="https://hackage.haskell.org/package/PSQueue"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.0
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >= 4.3 && < 4.13' 'base >= 4.3'
-}