summaryrefslogtreecommitdiff
path: root/dev-haskell/patience
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/patience')
-rw-r--r--dev-haskell/patience/Manifest3
-rw-r--r--dev-haskell/patience/metadata.xml21
-rw-r--r--dev-haskell/patience/patience-0.1.1.ebuild24
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/patience/Manifest b/dev-haskell/patience/Manifest
new file mode 100644
index 000000000000..6d4e89447ded
--- /dev/null
+++ b/dev-haskell/patience/Manifest
@@ -0,0 +1,3 @@
+DIST patience-0.1.1.tar.gz 4610 BLAKE2B 6ce8e959dec8493990f66c9cb7b5dc8aaef6cb4edc3207f19156ba527fd993112a29a9d39241a39c2d9c4af600cebdfd31f02833779ce6cbf74e14ce6305273a SHA512 dac94580d9b82023841b5406509f8cd0e58148756e4259708c21b78b480fb4fb67b21a82c81e702275f49d90bcd1d2b46d20bb96267131d4ff57334f110e14f7
+EBUILD patience-0.1.1.ebuild 588 BLAKE2B 41e54c710f9e2fbf9b659e02e204cf5a6df6efb58cdf10f5e4250fd56964fcf56008df1578c9f5f3d2b8ac15572783f002821029fe78f67cc01a3e06190ec65b SHA512 20b84cc967e553c831f2fa44fa96ce687313f3a2e50d31a3bee6538b03edb42fcfb10c03ba4629c3e90200260f275cba32f1b7695534497af4530bf796cd0c3b
+MISC metadata.xml 887 BLAKE2B 0cf15592802803b2efb4a61ec726a019abcb976bdec08c7389e3842fc0067c78aec5b96723fb3afd76c607428548bbc2ad46904f9be6edcdbf2363463d88ed4a SHA512 e6d6b6af598a2d92c07d1464c785f694f91e706ab2706909f4d1920c58764dc84856cadbed8008f337dfddc4ddb4431849b5688a7c6e50c28ff922680a766f78
diff --git a/dev-haskell/patience/metadata.xml b/dev-haskell/patience/metadata.xml
new file mode 100644
index 000000000000..2af4d28dc291
--- /dev/null
+++ b/dev-haskell/patience/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This library implements the \"patience diff\" algorithm, as well as the patience
+ algorithm for the longest increasing subsequence problem.
+
+ Patience diff computes the difference between two lists, for example the
+ lines of two versions of a source file. It provides a good balance of
+ performance, nice output for humans, and implementation simplicity. For more
+ information, see &lt;http://alfedenzo.livejournal.com/170301.html&gt; and
+ &lt;http://bramcohen.livejournal.com/73318.html&gt;.
+
+ New in version 0.1.1: relaxed @containers@ dependency, so it should build on
+ GHC 6.10.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/patience/patience-0.1.1.ebuild b/dev-haskell/patience/patience-0.1.1.ebuild
new file mode 100644
index 000000000000..dfdb7da7c939
--- /dev/null
+++ b/dev-haskell/patience/patience-0.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Patience diff and longest increasing subsequence"
+HOMEPAGE="http://hackage.haskell.org/package/patience"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"