summaryrefslogtreecommitdiff
path: root/dev-haskell/path/path-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/path/path-0.9.2.ebuild')
-rw-r--r--dev-haskell/path/path-0.9.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/path/path-0.9.2.ebuild b/dev-haskell/path/path-0.9.2.ebuild
new file mode 100644
index 000000000000..71683620a480
--- /dev/null
+++ b/dev-haskell/path/path-0.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -validity
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for well-typed paths"
+HOMEPAGE="https://hackage.haskell.org/package/path"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="dev"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-8.6.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/genvalidity-1.0
+ >=dev-haskell/genvalidity-hspec-0.7
+ >=dev-haskell/genvalidity-property-0.4
+ >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3
+ dev-haskell/quickcheck
+ >=dev-haskell/validity-0.8.0.0 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag dev dev) \
+ --flag=-validity
+}