summaryrefslogtreecommitdiff
path: root/dev-haskell/path-io/path-io-1.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/path-io/path-io-1.6.3.ebuild')
-rw-r--r--dev-haskell/path-io/path-io-1.6.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/path-io/path-io-1.6.3.ebuild b/dev-haskell/path-io/path-io-1.6.3.ebuild
new file mode 100644
index 000000000000..ace895dedc06
--- /dev/null
+++ b/dev-haskell/path-io/path-io-1.6.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface to 'directory' package for users of 'path'"
+HOMEPAGE="https://github.com/mrkkrp/path-io"
+HACKAGE_REV="3"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/dlist-0.8:=[profile?] <dev-haskell/dlist-2.0:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/path-0.6:=[profile?] <dev-haskell/path-0.10:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.4:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}